Email is not allowed


#1

Hello,

I’m trying to change a user’s email but it fails. Here’s what I tried…

  • through the Web at /users/foo/preferences/email where I get “Email is not allowed.” on a Gmail address (although Gmail is not in the list of forbidden domains). I test with an admin account and impersonating the user.
  • through the API with:
    curl -v -X PUT "https://#{api_host}/users/#{username}/preferences/email" -H "Content-Type: multipart/form-data;" -F "api_key=#{client.api_key}" -F "api_username=#{client.api_username}" -F email=#{new_email}

I’m using v2.0.0.beta10 +279. This used to work, or am I doing something wrong?


(Nichalas Petranek) #2

try this here


#3

Unfortunately, this didn’t work either.

Now I have: “You’ve performed this action too many times, please try again later.” Oops.

Note: the user is admin and moderator. Following the above instructions I had to remove both before deactivating the account.


(Nichalas Petranek) #4

i would suggest double checking the settings and subsequently double checking the spelling. If that doesnt work, send me a pm and i’ll try to help you further.


#5

I found out the email was in the ‘screened_emails’. I removed it from there and that solved the issue. Thank you very much!


(Julian Somoza) #6

And what’s screened_emails? How to access this table? via rails c?


#7

@Julian_Somoza
In Your Admin area within the forum

Logs > Screened Emails

/admin/logs/screened_emails


(Julian Somoza) #8

I see that! And the emails was there… Thanks a lot!