Empty page with strange entries in logs


(Staticinvocation) #1

Hi,

I’ve had a Discourse forum running for about a month now, but today I woke up with the forum returning a completely blank page. Restarting the docker instance did not fix the issue.

I tried running ./launcher rebuild which appeared to have worked, but when navigating to the page it works once, and then returns an empty page for every request thereafter.

I took a look in the log files and they are completely spammed up with entries like this:

2015-05-08 17:06:51 UTC [65-1] LOG:  could not open temporary statistics file "/var/run/postgresql/9.3-main.pg_stat_tmp/global.tmp": No such file or directory
Missing privilege separation directory: /var/run/sshd

Anyone know what’s up? I tried entering the instance already and touching the postgre file with no result.


(Reece) #2

I just did an update via the admin dashboard, and now my pages are blank as well. Looking at the page source, looks like it’s all there, just nothing is rendering.

I have the same exact log errors, but they predate today’s update, so I think probably unrelated to the current issue.


(Staticinvocation) #3

Nothing is working for me. No rendering, no HTML. I guess I had automated updates on or something because I didn’t manually update.


(Reece) #4

Well I found my issue: the discourse-akismet plugin, which I also updated along with the discourse-tagging plugin.

I removed discourse-akismet, did a rebuild, and my site is accessible again. I can’t imagine that this wasn’t tested prior to pushing out the Discourse 1.3.0.beta7 update…


(Staticinvocation) #5

I only have docker_manager, lazyYT, and poll plugins installed :expressionless:


(Kane York) #6

The askimet change has been rolled back, it should be safe again for you to update.


(Jeff Atwood) #7