Error during the update ESOCKETTIMEDOUT

Trying to update Discourse via the manual procedure

git pull
./launcher rebuild app

./discourse-doctor shows an error

I, [2023-06-16T11:39:43.530890 #1]  INFO -- : > cd /var/www/discourse && su discourse -c 'yarn install --frozen-lockfile && yarn cache clean'
error An unexpected error occurred: " ESOCKETTIMEDOUT".
Pups::ExecError: cd /var/www/discourse && su discourse -c 'yarn install --frozen-lockfile && yarn cache clean' failed with return #<Process::Status: pid 281 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "cmd"=>["su discourse -c 'yarn install --frozen-lockfile && yarn cache clean'"]}
bootstrap failed with exit code 1
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
==================== END REBUILD LOG ====================

The same problem when I tried to run
./launcher rebuild app

I tried downloading date-fns-2.29.3.tgz on a Linux host, and it works.

Connecting to (
saving to 'date-fns-2.29.3.tgz'
date-fns-2.29.3.tgz  100% |*************************************************************************************************************|  712k  0:00:00 ETA
'date-fns-2.29.3.tgz' saved

Discourse hosted on Alpine Linux VM

I encounter the same issue on ubuntu vps. not any clue.

I can’t tell if that’s the real issue or if you have an issue with docker networking.

1 Like