Error when installing with earlier unsupported version

Hello, I tried to install with an earlier version of discourse following instructions from another question, and went with v2.5.0

This failed with the following error:

> FAILED
> --------------------
> Pups::ExecError: cd /var/www/discourse && git fetch --depth 1 origin 2.5.0 failed with return #<Process::Status: pid 205 exit 128>
> Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
> exec failed with the params {"cd"=>"$home", "hook"=>"code", "cmd"=>["git reset --hard", "git clean -f", "git remote set-branches --add origin master", "git remote set-branches origin $version", "git fetch --depth 1 origin $version", "git checkout $version", "mkdir -p tmp", "chown discourse:www-data tmp", "mkdir -p tmp/pids", "mkdir -p tmp/sockets", "touch tmp/.gitkeep", "mkdir -p                    /shared/log/rails", "bash -c \"touch -a           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log\"", "bash -c \"ln    -s           /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log $home/log\"", "bash -c \"mkdir -p           /shared/{uploads,backups}\"", "bash -c \"ln    -s           /shared/{uploads,backups} $home/public\"", "bash -c \"mkdir -p           /shared/tmp/{backups,restores}\"", "bash -c \"ln    -s           /shared/tmp/{backups,restores} $home/tmp\"", "chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups /shared/tmp", "find public/plugins/ -maxdepth 1 -xtype l -delete"]}
> 6cc2109dd401fd326263e864fa09998776deb9099a40405110a909994e5e8b72
> ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
> ./discourse-doctor may help diagnose the problem.

When I tried with “stable” as the version, the forum installed fine. Seeing this I then tried v2.6.0 in case just that version was corrupted, but it also failed with the same error (only this time saying 2.6.0 instead of 2.5.0. Am I missing a step or should this have worked?

I see the tag exists:

My app.yml:

>   \## Which Git revision should this container use? (default: tests-passed)
> version: v2.5.0

2.5.0 won’t work with the current docker image. It’s also unsupported, as we only support the stable onwards.

How often does stable change?

My goal is to find a version and keep it for as long as possible as my use case is multiple forums across various forums, and I want them to all remain the same version for reporting purposes and automation.

Where can I find what version is stable?

Every six months, give or take a couple weeks.

New releases are announced in our blog, in the #releases category and you can also track the GitHub branch.

Got it. So If I want to maintain and older version of discourse on my servers I will need to maintain the older version of the docker image too? Or will the launcher always find the newest version of that as part of its build process?

AKA is it viable to copy an existing server I have to build the new one, and as long as the version was supported when that server’s docker image was created, it should still work? Or will I always be subject to the six month update window?

Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.