FAILED (./launcher rebuild app)

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle install --deployment --retry 3 --jobs 4 --verbose --without test development' failed with return #<Process::Status: pid 399 exit 5>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --retry 3 --jobs 4 --verbose --without test development'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

If you have plugins, I’d try removing all plugins then rebuild, see if that fixes it. Then add them back one by one.

1 Like

disabled all plugins
except - docker_manager.git

Which Git revision should this container use? (default: tests-passed)

version: ‘3d050bdaa31633a954758894629c0eb9fea537d0’

is there more to that error log ??

maybe check the logs @ /var/discourse/shared/standalone/log/

the .yml files are sensitive. You might have used a tab instead of two spaces somewhere.
Paste your file in this tool to find the culprit.


everything worked fine until today did not update docker manager *.yml files did not change

did you retry ./discourse-doctor ?

1 Like

Looks related to that :

yes ./discourse-doctor got the same error messagesstrong text

something is already using your https port

what is your platform/environment/host ? There is also a make error in your first screenshot :face_with_raised_eyebrow:

replaced the branch version tests-passed 3d050bdaa31633a954758894629c0eb9fea537d0 to 5e2e374c72f75d71c63c78a57edddde895b37e2a

it worked,

but I want to stay on > 3d050bdaa31633a954758894629c0eb9fea537d0

We don’t really test our base image with every single point in time specific commit, so there is no guarantee it will ever work.

It will always work with tests-passed branch, and that’s it. For everything else you are treading your own path, bugs and everything.