Failed Upgrade Discourse and Plugins

Hi. Tried to upgrade to the new version of Discourse and other plugins by pressing Upgrade All in the Docker Manager. However the upgrade failed.

Last Line was : Spinning up 3 Unicorn worker(s) that were used initially. See below

Tried restarting process, but now have the following two screens and it does not seem to let me use the Reset Upgrade button.

Welcome any advice. Many Thanks, Simon

The error should be higher up in this log.

You gonna have to wait until the background upgrade is done or errors out.

Thanks Gavin. It did error out, but I restarted the upgrade, which was probably a mistake. Previously the upgrade bar below “Upgrade discourse” was moving until the error notification, but now nothing appears to be happening.

I’ll wait and see if it errors out again.

FWIW, my upgrade of the Docker Manager errored out a small while ago with the same “Sorry, there was an error upgrading Discourse…”, and I just pressed the blue Start Upgrading button again and the Docker Manager successfully updated the second time (though it was slow). I’m currently now updating Discourse itself, and it’s taking awhile too.

(1GB Digital Ocean droplet)

Thanks Jammy… If it does error out, I think I’ll just plan to upgrade them one by one.

1 Like

My test site has successfully updated now, though it did take longer than normal. My admin UI forces me to upgrade Docker Manager before it will let me ‘upgrade all’, so that probably helped.

Thanks. How long did the whole process take? My progress bar is completely non-active so not sure how long I should wait.

My blue bar was moving, so I’m not sure I experienced the same stage as you’re getting at the minute. I’m afraid I didn’t time it, but I think the last ‘Update All’ took about 40 minutes, and the Docker Manager before that about the same?

@simonfen are you able to log in via the command line ?

if so, then do an launcher rebuild app

If you mean access the black box in the 2nd screenshot above, then I cannot access this. It is just black as in the above pic and unresponsive.

I’ve been waiting over an hour but nothing seems to be changing. Poss 90 mins.

no, i mean where you installed discourse the 1st time.

you login via an terminal and run a command

I think it seems to have corrected itself. I now have a report saying that all is upgraded except for two plugins that I’ll try and do individually.

I think even though the progress bar was not moving. It was upgrading in the background.

1 Like

yes, your version change from 2.8 to Discourse 2.9.0.beta1 and the site is still up.

so the upgrade did work

I tried to upgrade the solved plugin and got this error :
Upgrade discourse-solved error.docx (15.5 KB)

Then when I tried to go back to the upgrade page this error :

Though from my main Discourse page it does seem that the main upgrade has been done successfully.

i would recommend doing an ./launcher rebuild app from the terminal.


Thanks very much Gavin for your advice.

I didn’t install Discourse myself, but I’ll try and work out how to do that.

If you’re self-hosted, this has some good info in:

1 Like

Thanks very much JammyDodger.

1 Like