FAILED when try install plugin

Hey :wave:
I’m use latest version Discourse and havethis error when try install plugin:
How to fix the error to install the plugin?

<--- JS stacktrace --->

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory
 1: 0xb00e10 node::Abort() [ember]
 2: 0xa1823b node::FatalError(char const*, char const*) [ember]
 3: 0xcee09e v8::Utils::ReportOOMFailure(v8::internal::Isolate*, char const*, bool) [ember]
 4: 0xcee417 v8::internal::V8::FatalProcessOutOfMemory(v8::internal::Isolate*, char const*, bool) [ember]
 5: 0xea65d5  [ember]
 6: 0xea70b6  [ember]
 7: 0xeb4fee  [ember]
 8: 0xeb5a30 v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [ember]
 9: 0xeb89ae v8::internal::Heap::AllocateRawWithRetryOrFailSlowPath(int, v8::internal::AllocationType, v8::internal::AllocationOrigin, v8::internal::AllocationAlignment) [ember]
10: 0xe79b12 v8::internal::Factory::AllocateRaw(int, v8::internal::AllocationType, v8::internal::AllocationAlignment) [ember]
11: 0xe7443c v8::internal::FactoryBase<v8::internal::Factory>::AllocateRawArray(int, v8::internal::AllocationType) [ember]
12: 0xe74515 v8::internal::FactoryBase<v8::internal::Factory>::NewFixedArrayWithFiller(v8::internal::Handle<v8::internal::Map>, int, v8::internal::Handle<v8::internal::Oddball>, v8::internal::AllocationType) [ember]
13: 0x10d2afd v8::internal::Handle<v8::internal::NumberDictionary> v8::internal::HashTable<v8::internal::NumberDictionary, v8::internal::NumberDictionaryShape>::New<v8::internal::Isolate>(v8::internal::Isolate*, int, v8::internal::AllocationType, v8::internal::MinimumCapacity) [ember]
14: 0xd53916 v8::internal::Builtin_ArrayConcat(int, unsigned long*, v8::internal::Isolate*) [ember]
15: 0x15e7dd9  [ember]
Aborted (core dumped)
error Command failed with exit code 134.
Error running ember build
I, [2022-02-07T04:26:54.469601 #1]  INFO -- : yarn run v1.22.17
$ /var/www/discourse/app/assets/javascripts/node_modules/.bin/ember build -prod
WARNING: Node v16.13.2 is not tested against Ember CLI on your platform. We recommend that you use the most-recent "Active LTS" version of Node.js. See for details.
DEPRECATION: The integration of jQuery into Ember has been deprecated and will be removed with Ember 4.0. You can either opt-out of using jQuery, or install the `@ember/jquery` addon to provide the jQuery integration. Please consult the deprecation guide for further details:
Environment: production
info Visit for documentation about this command.

I, [2022-02-07T04:26:54.503554 #1]  INFO -- : Terminating async processes
I, [2022-02-07T04:26:54.505728 #1]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 42
I, [2022-02-07T04:26:54.508010 #1]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 103
103:signal-handler (1644208014) Received SIGTERM scheduling shutdown...
2022-02-07 04:26:54.510 UTC [42] LOG:  received fast shutdown request
2022-02-07 04:26:54.517 UTC [42] LOG:  aborting any active transactions
2022-02-07 04:26:54.532 UTC [42] LOG:  background worker "logical replication launcher" (PID 51) exited with exit code 1
2022-02-07 04:26:54.534 UTC [46] LOG:  shutting down
103:M 07 Feb 2022 04:26:54.565 # User requested shutdown...
103:M 07 Feb 2022 04:26:54.565 * Saving the final RDB snapshot before exiting.
2022-02-07 04:26:54.569 UTC [42] LOG:  database system is shut down
103:M 07 Feb 2022 04:26:54.678 * DB saved on disk
103:M 07 Feb 2022 04:26:54.678 # Redis is now ready to exit, bye bye...

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake themes:update assets:precompile' failed with return #<Process::Status: pid 1116 exit 1>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"assets_precompile", "cmd"=>["su discourse -c 'bundle exec rake themes:update assets:precompile'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

1 Like

Have you enabled HTTPS before installing this plugin ?

1 Like

Yes, of course, I’m installed the Discourse on this instruction:

1 Like

How much memory and swap do you have?

1 Like

How to find out? I’m very bad know the commands in terminal for Docker.
My server is Ubuntu 20.04, 1024 MB, 1 CPU

1 Like


That might not be enough nowadays. Try resizing it to something bigger. If you don’t resize the disk then you can always shrink it after the rebuild (assuming a platform like DigitalOcean)


I tried to spin up a new test site on a 1GB DO droplet yesterday, and that hit the same error. Resizing to 2GB and trying again worked for me. :+1:


Thank you!

Maybe Discourse remove this line in intruction to install.

Becouse Discourse have this error if work with 1 GB RAM.

The default of 1 GB RAM works fine for small Discourse communities. We recommend 2 GB RAM for larger communities.

Do you have a working 2GB swap on this 1GB server?

@RedBear try and rebuild now

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.