Bootstrap Failed, out of memory error


#1

I tried searching through the forum for troubleshooting but couldn’t find a similar error code that other people have encountered. Would someone shed light on what I have done wrong?

FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile' failed with return # <Process::Status: pid 318 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}    6a33a6d3658bf0bcba03364c855763ff6213a357b8190077daa6ddf9a9335bc1
FAILED TO BOOTSTRAP

I followed the standard installation procedure.
Many thanks in advance!


(Mittineague) #2

If you have the adsense plugin installed, please read this
https://meta.discourse.org/t/upgrade-failed-due-to-adsense-plugin/28671?source_topic_id=28800


#3

Thanks @Mittineague. Where can I find the AdSense file? Sorry I am new to coding.


(Mittineague) #4

In the “plugins” folder


(Jeff Atwood) #5

Can you clarify, are you installing for the first time? Did you follow our official install guide?


#6

But I have never downloaded the file? Am I supposed to do it in Terminal?

Yes I am installing it the first time. Yes I followed your official install guide.


(Jeff Atwood) #7

The most common error is bad formatting in the app.yml file. I suggest going back and making sure every single character is correct, including the correct number of spaces in front of each line.


#8

I replaced “example” with my own email and site credential and deleted the “#” in front of the line, where “#” exist for the line I made changes in. Are there other spacing rules that I might not be aware of?


#9
 LANG: en_US.UTF-8
 # DISCOURSE_DEFAULT_LOCALE: en

 ## TODO: How many concurrent web requests are supported?
 ## With 2GB we recommend 3-4 workers, with 1GB only 2
 #UNICORN_WORKERS: 2

 ## TODO: List of comma delimited emails that will be made admin and developer
 ## on initial signup example 'user1@example.com,user2@example.com'
 DISCOURSE_DEVELOPER_EMAILS: 'xxx@xxxxx.com'

 ## TODO: The domain name this Discourse instance will respond to
 DISCOURSE_HOSTNAME: 'xxx.xxxxxxx.com'

 ## TODO: The mailserver this Discourse instance will use
 DISCOURSE_SMTP_ADDRESS: smtp.mandrillapp.com         # (mandatory)
 DISCOURSE_SMTP_PORT: 587                        # (optional)
 DISCOURSE_SMTP_USER_NAME: xxxxxxx@xxxx.com      # (optional)
 DISCOURSE_SMTP_PASSWORD: xxxxxxxx               # (optional)
 #DISCOURSE_SMTP_ENABLE_START_TLS: true           # (optional, default true)

 ## The CDN address for this Discourse instance (configured to pull)
 #DISCOURSE_CDN_URL: //discourse-cdn.example.com

Here are my configurations (I x-ed out my credentials). I gather that everything is aligned?


(Jeff Atwood) #10

I suggest pasting the entire app.yml file in an online YAML validator like

http://www.yamllint.com/

If you are doing a simple install that’s the first thing to verify.


#11

YAMLlint says it is a valid YAML. What else could be the problem? :confused:


(Jeff Atwood) #12

Not sure we would need the complete install log, the error is usually upstream. Did you add any extra steps or deviate from our install guide in any way?


#13

No. The only thing I skipped was setting up Swap.


(Jeff Atwood) #14

Swap is needed for 1 GB RAM, but can be optional for 2 GB. Maybe attach a text file of the complete install log here.

I install from the guide multiple times per week and I have no issues. But I install religiously following the guide to the letter every step of the way.


#15

I tried the installation for the 3rd time but it is still not working. Here is the install log. Thanks a lot!
Discourse Installation 3.txt (216.8 KB)


#19

I followed the guide that @Qasem_h posted and it now works! Not sure if the extra step I took to update and upgrade the system had made a difference. Thanks a lot everyone!


(Jeff Atwood) #20

Looking at your logs, you hit an out of memory error. So not following the guide and setting up a swap file is what caused the problem.


(Jeff Atwood) #21