FAQ does not load when accessed from a topic page

Hello,

We have an issue on our site that I am also able to reproduce here: accessing the FAQ from the top right links fails to load anything when attempted from a topic.

It does work from other pages, like /latest for example.

You should be able to replicate it from within this topic too. If you try loading the FAQ from here, a white page will show with a spinner that never ends.

Are others able to see this? I am on a mac and this happens on both Chrome and Safari.

Thank you.

6 Likes

I can replicate it on Firefox for Mac.

4 Likes

Must be a recent regression - replicates here on meta in Chrome/Mac, but not in v2.4.0.beta1 +7.

@nbianca can you add that to your list?

5 Likes

Hi all,

I just realized this is also impacting PMs, including the first message users get from @discobot. He posts a link to the guidelines that also does not load.

This has caused confusion amongst some of our new users, and is also a missed opportunity to reinforce Discourse’s positive take on communication. This means that many new Discourse users out there (not just on my site) are experiencing a fairly jarring bug within their very first interaction. Not a great first impression. :grimacing:

I know this has been validated and will be worked on but I wanted to add this detail as well.

Thank you.

1 Like

Was looking at: Removing title from URL breaks links
And I think this should fixed it:

I’m trying to find if this is the best fix and also, when did he stop working, because the file I have modified haven’t been touched for a very long time.

5 Likes