Fatal error activating the plugin (/lib/utilities.php on line 23)


#1

Hello,

I’m the one who couldn’t use this plugin because couldn’t update cURL. I moved the wordpress installation to another host with updated cURL, and now when I activate the plugin I get this error:

Fatal error: syntax error, unexpected ‘[’ in /var/www/vhosts/XXXXX/denki/wp-content/plugins/wp-discourse/lib/utilities.php on line 23

Do you know why this could be happening?


#2

Nevermind. Used this beta version https://github.com/scossar/wp-discourse/tree/beta-php-5.3 that supports php 5.3.3, thanks. My apologies for not finding this sooner.


(Simon Cossar) #3

The problem with that is that version won’t be getting any updates. I made it for someone who’s forum broke after upgrading the plugin - the plugin now requires php >= 5.4. The plugin is supposed to give a helpful error message when it’s installed on anything less than that. I’ll fix that error message today, and also try to add a warning about curl when the forum URL begins with https. Php 5.3.3 is a very old version. It no longer gets security updates and really shouldn’t be used.