Wordpress Plugin Installation


(MorphZan) #1

Good Day

I have just created a brand new wordpress site
I have added the Discourse Plugin and have activated it and get the following message:

Parse error: syntax error, unexpected T_STRING in /home/myisp/public_html/forum/wp-content/plugins/wp-discourse/wp-discourse.php on line 41

I am quite new to this so was hoping someone could point me in the right direction

Thanks in Advance


(Jay Pfaffman) #2

When I have seen similar errors in the past, it has been due to using an old version of PHP, though it’s not entirely clear that this is the problem here.

What version of PHP are you using?


(MorphZan) #3


(Jay Pfaffman) #4

PHP 5.2 end of life was six years ago. PHP 5.4 has been unsupported for almost a year and a half. You’ll need to come into the modern era to use this code. See PHP Unsupported versions.

You may be new to this, but the PHP version you have is old. :slight_smile:


(MorphZan) #5

Ill be chatting to my Host immediately LOL

Thank you for the quick response!!!


(Simon Cossar) #6

Thanks for reporting this. The plugin runs a test that is supposed to prevent it from being installed when the php version is less than 5.4. It looks like that is failing because the test is run too late in the load process.


(MorphZan) #7

Got the plugin to install by changing how the .php file extension is processed
So running PHP Version 5.4 but the files are processed by PHP Version 5.6

I don’t know why this works but it does:


(Simon Cossar) #8

It looks like they give you the option of either using the system default version php, or setting your own version. The way you have it setup should be fine.