Forum is down (Error: invalid CSS)


(Maciej Orłowski) #1

Hi guys,

Our forum’s been down since yesterday. All we get when we log in / sign up is this Error:

The thing is, right now I’m not able to get into my admin to change the code and since Discourse is hosting our site, I’m not able to change anything. Tried reading some similar topics about entering the safe-mode, but it doesn’t work - my site doesn’t want to connect this way.

What should I do?


(Sam Saffron) #2

If we are hosting contact team@discourse.org and we will sort it out


#3

Looks like a very minor error in the CSS customisation.
Did you recently do any changes to CSS?

Also - how old is the recent working backup?


(Maciej Orłowski) #4

ok, thanks for the quick response!


(Maciej Orłowski) #5

the only thing I changed was I added a .gif file, but haven’t even placed it in CSS/HTML, so it shouldn’t change anything, right? After that, I think the forum stopped working or it’s a weird coincidence.


#6

Where did you add the .gif file
How did you add the .gif file?


#7

What’s the name of the .gif file
There is a chance that “some characters” used in the .gif file-name can also be the cause here. Just a guess.


(Maciej Orłowski) #8

the .gif file’s name is 300x250.gif, I uploaded it via Admin -> Custom CSS theme (don’t remember how it’s called exactly, but one can upload files there). Then I did nothing with it meaning I haven’t added it to the code.


#9

I’m guessing its the file-name that has caused the issue here.
I’m going to test this in my test site. And will let you know

If its really caused by the file-name - then this is a bug and we will alert the Discourse Team about it.


(Maciej Orłowski) #10

Super thanks for the help! :slight_smile:

I also think that might be the issue here. I actually uploaded this file here so that I can use the link somewhere else, I am super sure that I haven’t made any changes to the code.


#11

@Maciej_Orlowski
Could you please attach the .gif image here or else PM me the .gif image?
I will then upload it in my test site and let you know the result


(Maciej Orłowski) #12

Sure, this is it:

300x250


#13

I actually wanted to see the exact file-name.
Uploading it here isn’t letting me see the exact file-name
So, I have sent you a PM with my email address. You may send it there.


(Joe) #14

You already covered this but just to be 100% sure,

You have already tried visiting yoursite.com/safe-mode and that didn’t work, correct?

You should get a menu that allows you to disable the current theme like so:


(Maciej Orłowski) #15

yes, I’m getting the same error unfortunately (like the one I posted in the beginning of this topic).


#16

@Maciej_Orlowski
I uploaded the same file in my test site. But it didn’t create any issues

I’m guessing, it along with the existing CSS in your site is causing the issue.
If you have the CSS customisation saved somewhere - and if you’d like me to try it - let me know


(Maciej Orłowski) #17

Thanks for testing that. I’m guessing that it is it that caused the error with my CSS, because well, the error indicates this file’s name.

I unfortunately don’t have it saved anywhere and I can’t access the code, so I guess the best option for me right now is that Discourse Support deletes the file from their end?


(Maciej Orłowski) #18

Problem solved by the Discourse support (kudos for reacting really quickly!) - will let you know what caused this exactly.


(Régis Hanol) #19

The issue was that we used the filename of the uploaded file as SCSS variable name but it’s not allowed to have a SCSS variable start with a digit.

Won’t happen again (and sorry about that @Maciej_Orlowski)


(Maciej Orłowski) #20

Understood - thanks for reacting really quickly!