Forum Offline, Trouble Updating

My forum is offline

And I tried updating it

but below is the error I get

102:signal-handler (1678624734) Received SIGTERM scheduling shutdown...
2023-03-12 12:38:54.291 UTC [41] LOG:  aborting any active transactions
2023-03-12 12:38:54.295 UTC [41] LOG:  background worker "logical replication launcher" (P
ID 50) exited with exit code 1
2023-03-12 12:38:54.297 UTC [45] LOG:  shutting down
102:M 12 Mar 2023 12:38:54.326 # User requested shutdown...
102:M 12 Mar 2023 12:38:54.326 * Saving the final RDB snapshot before exiting.
2023-03-12 12:38:54.326 UTC [41] LOG:  database system is shut down
102:M 12 Mar 2023 12:38:54.385 * DB saved on disk
102:M 12 Mar 2023 12:38:54.385 # Redis is now ready to exit, bye bye...

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle install --deployment --r
etry 3 --jobs 4 --verbose --without test development' failed with return #<Process::Status
: pid 405 exit 5>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.
rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -
c 'bundle install --deployment --retry 3 --jobs 4 --verbose --without test development'"]}
bootstrap failed with exit code 5
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may 
be more than one.
./discourse-doctor may help diagnose the problem.

Please include more lines - maybe 50 previous lines will be enough.


Fixed and OhK now

Thank You

What did you fix?

(+20 characters)

I guess the problem is

fatal: detected dubious ownership in repository at '/var/www/discourse'
To add an exception for this directory, call:

        git config --global --add /var/www/discourse
1 Like

So, i tried some random commands but seems the one below fixed it

git config --system --add /var/www/discourse

I had a custom docker .yml template. In the end what solved it for me was to do something like this: