Fresh Install gives "Too many redirects" error

I ran through the cloud setup guide on DigitalOcean.

The installer seemed to install everything okay, but when I try to open the website in Chrome I get a “too many redirects” error.

1 Like

It looks like the redirects are pinging from the A record in Cloudflare I added to the IP of the DigitalOcean pod and back again.

You should follow the Discourse official Standard Installation.

It sounds like you have a dns problem, but I can’t guess what.

1 Like

Your DNS controls should be accessible from the place where you purchased your domain name. Create a DNS A record for the hostname in your DNS control panel, pointing to the IP address of your cloud instance where you are installing Discourse.

I followed the above part of the guide and pointed the DNS to the DigitialOcean, but they just redirect to each other now - presumably because the host in the Discourse setup is the A record value so it’s just stuck in a loop.

1 Like

Turn off the orange cloud. At the A record to your droplet ip. Follow the official obstructions rather then the digital ocean instructions.

1 Like

Thanks, setting the proxy status to DNS only fixed it! :raised_hands:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.