Full Name of user not shown in posts

I have the turned on the setting “display name on posts: Show a user’s full name on their posts in addition to their @username”.

It works, but not on all users. I have found a user that I can only see his username, not the full name in posts.

Is this a setting that can be overridden by the user?

PS. I want my community to be based on openness/transparency so I don’t like any user to hide his/her name.

This happens when the username is very similar to the full name, could that be the case?

The same is happening with your own user here on meta (although meta shows the full name in that case)

3 Likes

Ah yes that must be it, thank you. However, I would like to change that behavior, if it is possible in admin settings somewhere?

I rather show the full name than only the username, but I would prefer to always show both even if they are similar.

If a user leaves their “full name” blank, then the only thing you’ll see is the username. Some users may only fill in their first name, some full name. Unless you make it a required field, not everyone will comply. :wink:

Not possible to display that redundant info when name and username match, no.

1 Like

Well, the username is without space, so it is not clear what his name is:

Username: medhathanbali

If “redundancy” is not possible. How then can I show their full name instead of username in these cases when they “match”?

I believe the setting is called “prioritize username” and it is on by default, you are seeing the effect of changing that site setting right here on meta, look at your post :wink:

2 Likes

Ah perfect, found it! :slight_smile:

2 Likes