Getting "config file was not found, ensure containers/.yml exists"

Everything seemed fine the last time I checked, although I havn’t checked in some time.

Install was done following the official docs, on a DO server.

Rebooted server but same issue.

Tried to run ./launcher restart but get the following error:
Config file was not found, ensure containers/.yml exists

Running ./launcher rebuild produces the same error.

Just noticed the file name of the .yml file should usually be app.yml? I checked the containers folder and the file is named app.yml.

Why is it trying to look for .yml?

The command is

./launcher rebuild app

not

./launcher rebuild

1 Like

@pfaffman it might be good to add an informative message in this case rather than looking for a blank .yml file.

1 Like

Well, I’m generally afraid of messing with launcher as it’s the only way to break every install on the planet. :wink:

If you give launcher a file that doesn’t exist it suggests the ones that do. I’m surprised that it doesn’t do that with no argument.

My fears aside, I’ve got one fix to discourse-doctor on my list. I’ll try to add an argument check to launcher when u do that.

2 Likes

That’s true, do you think we can make a “filename exists” check here @tgxworld without breaking stuff?

Done in

4 Likes