Gmail & other popular email services not receiving my email

DISCOURSE_SMTP_PORT: 587 # (optional, default 587)

DISCOURSE_SMTP_USER_NAME: login # required

#DISCOURSE_SMTP_PASSWORD: pw # required, WARNING the char ‘#’ in pw can cause problems!


If I enable the username and password it gives me a 500 error about command not recognized. If I don’t, the logs say the email is sent and it DOES send to my account on my domain if i say to, but it does not send to gmail or yahoo emails.

I have an SSL cert that I tested and is valid. I have tried multiple things and spent around 14 hours trying to get this working. I don’t know why its not sending, the same things are used for my other services, and they both are capable of sending to gmail and yahoo.

At what stage of the delivery process is it failing? What do the relevant logs say about the failure?

Hey, sorry, I am just looking at it still. I found it’s being denied by the providers, probably bc I don’t have login enabled, but in that case i can’t because it says the command is unrecognized. I am trying to look into how to enable that (I am pretty sure its bc discourse is in its own docker container sending the email not on the location the mail server is directing from and therefore its not auto validated by the server and needs authentication or for the mail server to allow from that ip without authentication)

Now that i said that i just realized i can allow from a domain in without signing in… which means i just need to find the ip for the docker container and maybe that will work

You don’t happen to know one of the following:

  • How I would make it so’s server lets me use auth login
  • How to find what external ip the docker container is sending from

No. That would be a question for the support people.

docker exec app curl
1 Like

I figured it out actually :slight_smile: Thanks for replying to me, if you hadn’t I wouldn’t have typed that long message and figured it out lol.

Found the ip with docker inspect then i added it to so that it would allow not authenticating with that ip.


I’ll be a rubber duck any time.