Google Fonts

I’ve just followed the various instructions on changing the fonts on my forum: these are the steps I followed. I’m hoping this is a good place to ask for help.

Admin → Customize → Themes

Install button

Choose: “From a git repository”

Enter: GitHub - discourse/discourse-google-font-component
(it installed fine and gave me a nice Discourse form to fill out, which I did with the fonts I’m interested in trying out)

Preview → this is where it stopped working – all I get is my site using the default Arial, no sign of the fonts I want to see.

I’ve entered font names that I know are present in the site, I just went through a whole bunch to pick the five candidates. But perhaps I’m not using the right format? I entered them thus: “Libre Caslan Text” “Gentium Plus” “Oranienbaum” without any of the other font specifiers.

This is a screen shot showing what I entered, at the top of the form:

What do I need to do differently?

1 Like

Hmm these same settings are working for me, so I’m not sure what the problem is…

(I’ve got the theme component enabled, so you can see that the theme setting text is rendered using Libre Caslon)

If you right click the page, select “inspect” and then “console” — are there any errors listed?

1 Like

Ah, I finally checked back, and tried your suggestion: preview, Inspect, Console. This is the error message I see:

The resource from “” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff).

I have no idea what to do about this. Any suggestions?

Quick bug report: I just noticed when I set the font weight then bold text doesn’t show up as bold.

I tested this with the fonts Work Sans and Zilla Slab. I changed the font weight from the default (400) to 300. When I did this bold text did not appear bold. Reset that setting and the bold text reappears.

I set it to 400 and called it a day, but wanted to let you know.

Thanks for your work on this!