Google Suite and "Notification Email" return address

Hi there!

I’ve just recently switched my SMTP settings for Discourse to use Google Suite (Gmail) for mail instead of my custom hosted mail server that I used before. One of the big reasons that I decided to do this is because previously, users with a or email address wouldn’t be able to receive emails from our forum, which would result the user(s) having to contact an administrator to get their email verified.

So, I successfully switched the email over to GSuite, and I created a test GMX email and I was able to receive emails perfectly, great! However, I noticed an issue. Previously, I was sending email through (which is run through my own mail server hosted on Azure), and I’d have the [“notification email” option set to (see here). This would work perfectly, making the email show up like it would arrive from (see here).

Now that I’ve switched to GSuite, the email now arrives as instead of the configured (as shown here).

Is there anything I can do to fix this without having to create a new user in GSuite with the email and sending the mail through that account? (This would be the easiest way to handle the situation, however it would result in me adding a new user, which is more money.)

Support or any ideas would be greatly appreciated, thanks!

Just an update:

Previously I didn’t configure the domains MX, SPF, and DKIM records to match G Suite. They’re properly (at least I’m assuming) configured now, and you can check the status of them using Google’s Check MX tool. The problem still occurs. Not really sure what to do at this point.

Gmail will rewrite the from address to the authenticated user.

You can verify another email address on your account to prevent this rewriting.

Be warned that using gmail this way will cause you grief.