Help us test the rewritten Composer

feedback

(@SenpaiMass) #139

I did get this from a long time, I was considering this to be a functionality of the way the composer works maybe i am wrong?


(Daniela) #140

I’m pretty sure the ‘old’ composer works clicking B+I too. I don’t know if his current behavior is a bug or not.
@eviltrout surely knows.


(cpradio) #141

It seems because italic is using * versus _. And if you bold first, it sees there are surrounding * around the text so it removes one set of them. If the italics used _ it would remove this conflict.


(Robin Ward) #142

I originally did it that way to maintain compatibility with the previous editor. Now that it has been fully retired I’ve changed it to _ and it seems to work:


(Miguel Ángel López Vicente) #143

Finally we have this option?


(Sam Saffron) #144

Not yet… but I want it


(Dave McClure) #145

As someone who personally prefers the inline style, I would be in favor of having the composer button only do footnote style, rather than add another option, since inline is easy enough to do manually.


(Erlend Sogge Heggen) #146

There’s a tiny feature regression here. You can no longer revert formatting in an arbitrary order.

Try edit my post, highlight this word (**_word_**) and click the B button to remove the bold formatting. You can’t; it’ll apply another round of bold formatting. You have to remove the italicisation first.

Now try removing bold formatting for this word (***word***). It works.[quote=“mcwumbly, post:145, topic:34679, full:true”]
As someone who personally prefers the inline style, I would be in favor of having the composer button only do footnote style, rather than add another option, since inline is easy enough to do manually.
[/quote]In retrospect, I’m perfectly okay with this too. I miss the space-preservation :confounded:


(Tobias Eigen) #147

Continuing the discussion from Email Notification recipients unclear when PM is sent to multiple users:

Is this a bug with the rewritten composer?

The following markdown…

Good point. Maybe a line could be added: "You received this because it is addressed to you, along with `@foo` `@bar` `@foobar` and `n others`.

presents the following with missing spaces between preformatted text:


(Dean Taylor) #148

Looks like this bug to me:


(Jeff Atwood) #149

What about ctrl+shift+u for upload? This does nothing on my keyboard.


(Rafael dos Santos Silva) #150

Nooooo. This starts unicode mode on Linux (at least on my ubuntu machine).

CTRL+SHIFT+U B 0 makes a ° for example.


(Dean Taylor) #151

Something that perhaps visually makes sense is ctrl+shift+^

The caret character, not the up arrow, for me this is written above the 6 on the number row on my keyboard.


(Peter N Lewis) #152

Ctrl-Shift-^ / 6 looks ok to me on the Mac. Might be a problem on international keyboards though.


#153

As @peternlewis said, it is not quite possible on my French keyboard where ^ is not on the sixth key and ^ has a special effect key to combine with next pressed key.

Speaking of which, current keyboard shortcuts based on number keys do not work on French keyboard, where numbers are not the main glyph of those upper key row.

As was already said on another topic, Ctrl+Shift+g seems ok:


(Jeff Atwood) #154

No, I think you misunderstood that discussion.


(bluej100) #155

One minor bug: on Android Chrome, my selection seems to jump around. For example, frequently when I edit a post and click in the middle of the text, my caret is placed in a different spot from where I clicked.


(Miguel Ángel López Vicente) #156

Do we have any news?


(Sam Saffron) #157

It’s in the PR welcome camp… not on our roadmap, I would like the option but no time to build it.


(Jeff Atwood) closed #158