Home logo url points to the root of the domain even in a subfolder install?


(Nick) #1

I just noticed that the logo (home) url points to the ‘/’ of the domain in my subfolder installation and yet, when I click on it, in most cases it correctly brings me to the root of the community, which is ‘/forum’ in my installation. Is it supposed to be like that? How is it implemented?

The reason I bring this up, and how I noticed this in the first place, is that it somehow broke down for me earlier today. I.e. clicking on the home logo began bringing me to the root of the entire website, not the root of the community. I then rebuilt the container and it seems to have fixed it.

How how exactly does this work and why not put the correct community root url in the header in the first place?


(Ben) #2

I have the same question/problem. How to change the behavior to link to the root url and not to the Discourse Main page?


(Rafael dos Santos Silva) #3

Do you want to make logo go to the main domain right?


(Ben) #4

It’s not working. It points to https://example.com, but it redirects to the https://example.com/forum


(Rafael dos Santos Silva) #5

If it still not working we need to ping @eviltrout because the fix above didn’t work then =(

I was an avid user of this, but I’m not using subfolder anymore, so I can’t test.


(David) #6

I have the same issue.