How do I disable discourse narrative bot (discobot)

So here’s the thing. I finally got Discourse set up on my site (thanks to @HAWK and @pfaffman :D) and I got the usual private message from discobot trying to teach me how to use discourse.

I ignored it because, well, I already know how to use it so, just kept going adding new users, categories, seeding discussion, the usual stuff. Except, I end up with this thread talking about discobot. If Discourse doesn’t stop trying to teach me how to use it I am going to freaked it

From my phone, I read it and replied “I’m not a fan either, I’ll see if I can disable it.” I head into the admin panel, tap “Users”, scroll down to discobot, tap it, and I start looking for some way to suspend or silence him. I click the silence button, set the timeframe to “Forever”, and the reason to “please stop teaching us how to use discourse it’s annoying people”, click “silence”, it errors out.

I notice he is also admin and trust level 4. Although I can’t de-admin him, I can still set his trust level to 0 and lock it. So I do.

I also notice that I can’t delete all his posts from that page or delete him because he’s admin. Yikes. But, there is one thing I CAN do. I can impersonate discobot.

Noticing this button, a great idea pops into my head. “I just came up with the best prank ever!” So I click the button, and I am now discobot. I have assumed his identity.

I navigate to that topic, hit “Reply”, and simply type the following:

You cannot delete your lord and savior. [clicks “Reply”]

Needless to say that’s gonna cause some backlash when people either think that discobot has become sentient or find out that it was me abusing that “Impersonate” button, but, my god…it’ll be worth it.

In all seriousness though, how does one ACTUALLY disable discobot?

5 Likes

There is a site setting for it :wink:

2 Likes

What would that be? I went into Settings and searched “Discobot”, no results found

1 Like

Oh my, let me search for it. I’ve managed to remove it (almost) completely, as our community does not have heavy load and I prefer to send welcome message to our users from a real person, but I have other instance.

1 Like

Uncheck “discourse narrative bot enabled”

6 Likes

Thanks! That should work perfectly. :slight_smile:

I reckon we should at least add “discobot” in the description of the related site settings.

10 Likes

Yeah, though it’s still fun to make people think that the rise of the machines is ever closer. :slight_smile:

1 Like

The term “discobot” is internal use only … everywhere in our locale files we use “narrative bot”. A search for bot would do the trick. Mixed on adding “discobot” into the text just for this one setting.

It used to be a bit simpler to learn about this prior to us suppressing “narrative bot” from the plugins page. But I think “Bot” does the trick so this thing can be closed.

3 Likes

Except it’s also the username of the bot :wink:

So not “only” internal.

2 Likes

Sure I am fine to add it then