How do I get rid of "We've updated this site, please refresh..." message?

This message appeared earlier today after upgrading my Discourse forum:

This is the first time I’ve seen this. Do I have to do something to get rid of it? Refreshing, changing browsers, changing computers, logging out did not help.

4 Likes

It looks like you might be missing some CSS files… how did you run the Discourse update?

2 Likes

I used the /admin/upgrade utility.

1 Like

I’m having the same issue after upgrading this morning from 2.7.0.beta5 to 2.7.0.beta6.

I upgraded via the /admin/upgrade util as well.

Force refresh on the client side did not fix it - not even a developer “empty cache and hard reset” nor an incognito window.

I even tried restarting the whole app (./launcher stop app and ./launcher start app in the docker container) and it still won’t go away.

Thinking it looks like a bug?

2 Likes

I had this issue as well, and doing this resolved it:

cd /var/discourse
./launcher rebuild app

I don’t know if it was the right way to handle the issue, and it did involve some downtime, but it did work.

4 Likes

That worked, thanks!

Hi, I also got this issue, and @JamesChevalier resolution worked.
Just wanted to +1 for visibility that we were also affected.

Me too, refreshing doesn’t remove the annoying message. Will try the manual update.