How to fix my SEO?


(Uncle) #1

Hi folks,

When i search for my site in google. I see the following.

Looking for advice on how to fix it with a description.

Many thanks in advance folks

Cheers


(Mittineague) #2

If you go to your Admin Settings you should be able to find “locale”.

If you change that from English to your preferred language the description should then be in that language in search results.


(Evgeny) #3

Your Google site sees this.

You can redefine the file:

views-site/list/list.erb

Add there what Google requires
Namely the title page (h1) and a small text.
Note that a similar page and tex header should be similar to another version of the site. Because Google compares the options.

Any page should have a title.

For example

Design of titles inside the text, tags H1 - H6
Correct layout of titles inside the text helps a user to understand faster what is on the page, i.e. saves time. In addition to that, it helps Yandex robot to figure out the document structure as well. Because of that, you should highlight the titles with these tags according to the document structure.

© source

Similar rekomandatsii there are other search engines. Since all the algorithms work in the title-h1-dependence, etc.


(Uncle) #4

THe erb was ok. All default. I had installed a sitemap plugin. Not sure if that is the issue.

https://forum.putput.in/sitemap.xml

These are the setting in locale

Source looks ok to me

I read somewhere, that Discourse does not need any separate sitemap plugin. Is that true?


(Uncle) #5

I have taken the sitemap.xml off and rebuilding the app as I write this.


(Uncle) #6

It was that sitemap plugin giving issues. After I took it off. I made google crawl the site and now, it looks better.


Thanks all for your advice.
Cheers


(Sam Saffron) #7

@vinothkannans I would like you to do some root cause analysis here, can not have the sitemap plugin break sites, that is terrible.


(Vinoth Kannan) #10

Hey @uncledavy, I don’t think it is problem of sitemap or any other. I am able to see other websites which are using sitemap feature are rendering fine. Maybe it looks like that because of your website is new (or you only submitted your website to Google very recently). Normally Google will take some time to render the search results properly for new websites.


Google search problem
(Uncle) #11

Thanks. I will install the plugin again.