I have a question about configuring the mail system

Hello! I come from China, the following is from translation software

This is my first time to use the international forum. If there is a low-level error, please help me correct it

I am using /var/discourse/discover-setup to configure “discourse”,
But I have a big problem with email.
I tried to move the mailbox configuration of other forum software,
when I try to send mail,
Then I found that the mail was sent to this strange address.
And I was very upset that I didn’t receive the email correctly.

Here is my Foxmail software configuration, which can work normally:

(I cant upload image and https address :frowning: )

I have tried a variety of configuration methods, please help me point out my configuration where there is a problem!

I can try my best to add the missing information in the post.

If you can help me solve this problem, I will be very grateful!

FoxMail: Foxmail for Windows

Add: I use Alibaba enterprise email
AliMail Enterprise Edition (aliyun.com)
If you need to test, I can provide you with an account number

UUID@hibot.top is not the email address used, it is the Message ID for the particular email that was sent.

When you try to send a message, does any error show up on the logs? – https://forum.hibot.top/logs/

1 Like

(sorry im late

i clear the log and send again and the log have nothing in it (sry for my broken english

Thats Log in SideKiq

im still in trouble
please help me thanks!
i reinstall it and try to send verify email,thats the logs:

Could your firewall block port 465 ?
telnet smtp.hibot.top 465

I connected for 10 sec and it disconnected
And thanks for your reply (When you reply, the time here is 1pm and im sleeping

You can run the discourse-doctor directly in discourse folder, and the MAIL TEST section of test result may help a lot.

I recommend to using the DirectMail(邮件推送) which also Alibaba product with some free quota, it just like Mailgun.

i tried,but the error is same:end of file reached

I use Business AliMail because its free :smiley: ,but i will try directmail ,thanku

It could be the port 465 issue.

1 Like

Ok,I am checking this post
And DirectMail its 2 expensive for me i cant send 50K mail in 6month,and it cost me 11USD
My Server only 3.5USD/month :joy:

1 Like

You ignore the last section.

And if you want to keep using the Busisses Email you can try if it can support other port.

1 Like

oh im blind(but DirectMail running in 465 too
thank for you replying ,Thats Helpful to me
I think port 465 problem should add in this post: Troubleshooting email on a new Discourse install - howto / sysadmin - Discourse Meta

1 Like

You can using port 80 if you don’t really need SSL/TLS, it’s working to me.

ok i will try thank u

Just added some more words saying that 465 is usually wrong :slight_smile:

1 Like

wow,thank for u help😀

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.