I Have an Issue With Swap File (2GB) During Installation


(Elo Tobore Murphy) #1

Hello,

I am currently having issues with the last step of discourse installation. I got this reply from my from ssh client while trying to enter " ./discourse-setup"

Please what should I do?


(Joshua Rosenfeld) #2

From the output you provided it would appear that you have a 1 GB swap file, not a 2 GB one as required by Discourse. I’d suggest disabling the existing swap file by running

swapoff /swapfile

then running

./discourse-setup

again so it can create the 2 GB file. Did you previously set up a 1 GB swap file?


(Elo Tobore Murphy) #3

Yes I did set up a 1GB swap file because it was part of the instructions in vultr instruction documentation


(Joshua Rosenfeld) #4

This? How to Install Discourse on Ubuntu 14.04 - Vultr.com Those docs are pretty outdated: Modified on: Thu, Feb 26, 2015 at 12:32 pm EST

The up-to-date instructions are here:
discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub


(Elo Tobore Murphy) #5

I have turned off swap file but am still getting an “insufficient swap space” message.


(Jeff Atwood) #6

I suggest resetting your VPS with a clean Ubuntu Server 16.04 install and starting over from scratch.


(Elo Tobore Murphy) #7

Ok I will try that now. Thanks


(Elo Tobore Murphy) #8

[quote=“codinghorror, post:6, topic:57028, full:true”]
I suggest resetting your VPS with a clean Ubuntu Server 16.04 install and starting over from scratch.
[/quote]I have done what you said but am still having problem with the swap space stuff. Please what do I do?


(Jay Pfaffman) #9

The easiest thing would be to use digital ocean.

You could try to create a 2gb swap file yourself. If you do that and are still having trouble, include the output from

free -h