Images on polls do not work properly in beta 6


(Daniela) #1

Yesterday I tried a little custom CSS on polls, so I look the old polls to see it an action.
I see that polls with images are all broken like the poll above.

Can Discourse Team make a little fix please?
Thanks!


(Stephen) #2

Did they work previously? None of the stuff from the team has demonstrated image polls. The last update doesn’t mention them at all.


(cpradio) #3

Yeah, I think this was out of scope or not planned to work with polls


(cpradio) #4

Second thought, it may be wise to make images in polls more thumbnail like.

.poll img {
  max-width: 120px !important;
  max-height: 90px !important;
}

(Stephen) #5

I’m sure there are ways of fixing it, but if it’s not a feature then this almost certainly isn’t a bug.


(Daniela) #6

Yes, when I created the old poll with images it certantly works (or I deleted it).

Thanks, I try this little fix.


(Schallmeister) #7

Is bumping an old thread against the rules on here? I didn’t see it if it was.

Anyways, I was going to make a thread with the issues I’m having, but the new user restrictions on here disallow me to do that.

Over on another Discourse forum (I’m not sure if I’m allowed to link there) there was an issue that came up where it wasn’t allowing a user to add images to a poll correctly. He was uploading the images directly from his computer and when looking at the preview for the post/poll, the images were loading correctly, but when the post was made the images weren’t there, but you can see the image directory/link.

This is the end product:

As a mod for this forum, is there anything I can do on my end?

Edit: the forum is version is v1.9.0beta4+177


(Régis Hanol) #8

Let’s try this

  • image
  • image
  • image

0 voters


(Schallmeister) #9

What is it that you did? Was it just something this person did wrong? This forum I moderate just switched to Discourse but six months ago so I don’t really know the ins and outs of it yet.


(Régis Hanol) #10

I just tested it worked here so I know it’s not a bug (or not anymore).

I would first suggest asking the admin to update to the latest version so we’re 100% there’s no bug.
Then I would “rebake” the post (ie. click the Rebuild HTML button).


(Schallmeister) #11

Ok, so we switched to using a GIF and it’s the same issue. However, that same GIF in the poll works fine outside of the poll.

I’ll have to get ahold of an admin to see if they can update the forum.