Imgur GIF link is no longer embedding

Before I posted a link and it already incorporated the GIF, now I post the link and it doesn’t embed anymore

Some IMGUR links embed as GIFS, while other LINKS just stay LINKS

I always left this site open, and it always worked normally, now that it’s giving this error, some links embed gifs, others don’t

I do not know what to do, nothing embodies! The links did not turn into a gif, what can I do?

1 Like

I’m afraid my gif experience is minimal, but in the screenshot above it looks like you’ve added imugr to the disabled image download domains. You could try removing those entries, and seeing if that helps?

Even disabled it doesn’t change anything, links don’t embed gifs

I can confirm on recent update this fails now for me too.

disabled image download domains is empty for me

please if you find any solution let me know, my forum members are driving me crazy, and i don’t know what to do! How do I not update the discourse automatically?

[image]

1 Like

@Danielabc you could check to see if you are being blocked.

My plugin: "Onebox Assistant", crawl for those previews reliably! uses a well-priced third party service to crawl external sites, avoiding exposing your own identity directly.

I just tried it with Imgur and it worked for me.

Let’s see:

https://i.imgur.com/6XQqUaB.gif

this embeds / oneboxes fine here, so there’s some kind of problem between your server and imgur.

1 Like

Let me see if I understand, the error of not embedding GIF can be from the server? That plugin you passed me to help my server embed gif? Is he paid? Where to buy?

My plugin is free. The service required to use it is not ( I’m not affiliated). The service used is ‘embed.rocks’. It’s linked in the description.

This happens all the time to individual sites. Some kinds of remote sites are worse than others. Finance news sites are some of the worst, for example.

1 Like

Thanks for answering me and showing me this plugin, but I can’t pay for the service, because my forum has a lot of access, so it would give a considerable amount for me to pay… How can I solve this issue without having to pay for it? In this case, why before I could embed GIFs through IMGUR and now I can’t? Is the problem on the DIGITAL OCEAN server? What do you think I should do? Complain to them? I don’t know what to do and I’m desperate because my members can’t incorporate anything from Imgur anymore and they’re pressuring me to fix it

What I find funny is that some links don’t embed and others embed, and all of them are from IMGUR, look at an example below, what could this be? I don’t know how to solve it anymore, my members are all crazy pressuring me to solve this but i don’t know how to solve it

[image]

1 Like

This is a perennial problem faced by all discourse sites at one time or another depending on what sites they are attempting to crawl.

From their help:

I quote: “ We allow hotlinking on forums, but these images cannot be used as content for a website, including blog posts, avatars, site elements, and advertising. You can read our terms of service for more info. If you believe your site has been mistakenly blocked, please contact us for assistance.”

It might be they are not classifying Discourse sites correctly.

So options:

  1. Try contacting them to see if hey are blocking you for some reason. You may be able to remove any specific IP block. Possibly try getting the Discourse User Agent to be whitelisted as it is a forum system. They might not be recognising it as such at the moment. You’d be doing the community a favour?

  2. Another option might be to move IP address, but if your site is a heavy user you may end up back in the same place as they start blocking that address after so many links.

  3. A final option is to bite the bullet and use the proxy crawl service whilst monetising the site further to get your users to pay for it.

2 Likes