How to disable links turn upload?

If I post a link to a gif from IMGUR, some time passes and it becomes a link to my own forum ( As if it was uploaded to my forum) how can I disable it?

Is this the same issue you are posting here? How to disable HTML on the forum?

Search for “hotlink” in settings to configure this behaviour.

1 Like

Hi koliwi,
Can you please read my message here:

And confirm that this is the issue you’re trying to solve? If it is, there is no need for two topics, and then I’ll delete this one :slight_smile:

1 Like

This problem is about links from any site (IMGUR) becoming an internal link (FORUM), so if I post a link from an outside site, some time passes and that link starts to have its content uploaded to my forum, as if I took the link from my forum, since the other problem in the other topic would be about HTML, I wanted to disable the use of HTML in the posts

If you don’t want external files being automatically uploaded to your forum, disable the download remote images to local in the admin settings. :slight_smile:

Note that this setting only affects images, and Discourse never automatically downloads remote files other than images.

perfect, I just didn’t understand the ending (I don’t understand English, I use a translator that must be why)

Did you say that this only applies to the image? Does that mean that if I post a link to a video it is uploaded to the forum?

I have another doubt too, when I’m going to use a link from my own forum, why isn’t it embed like the other links? Example, I use IMGUR link and it embed in the posts, but my forum image links as the avatar, it is not embed, example


Here in your forum the image link is embedded

but in my forum if i post the link of the avatar in the topic, it is not embedded, only the link of the image is, it only embeds if using a boring HTML code and difficult to type

In my forum, if I post the link, it’s just the link

I have to use this code to show the embedding, something difficult


The download remote images to local setting only concerns images. Have you encountered issues with other file types from your users?

I’d be happy to help you, the best would be that you to send me a link to your forum, so I can register and see it by myself. But please take note it can take a while as it’s the weekend. I might take a look next week. :slight_smile:

Could you share a link to your actual forum You can send me the URL in a personal message or chat. These screenshots won’t help in this case, unfortunately.