Imported backups not appearing


#1

We have a docker based installed, running the latest version ( [v2.0.0.beta5 +141]).

Trying to check our backups, so have a second server also running the same version. Have created a backup on the primary server, but when I upload to the second server, the backup never appears in the list.

Have checked the logs and it has the following error:

Job exception: No such file or directory @ unlink_internal - /var/www/discourse/public/backups/default/forum-2018-04-03-114255-v20180328180317.tar.gz

If I check the backup directory (/var/www/discourse/public/backups/default), there are no files.

In the “tmp” sub directory there is a file:

/var/www/discourse/public/backups/default/tmp/forum-2018-04-03-114255-v20180328180317targz

Very strange as haven’t had any issues before with the backup/restore function


(Richard - DiscourseHosting.com) #2

Do you have enough free disk space? You need at least a few times the size of your backup.


#3

Think so!

Filesystem      Size  Used Avail Use% Mounted on
overlay         227G  5.9G  209G   3% /
tmpfs            64M     0   64M   0% /dev
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sda1       227G  5.9G  209G   3% /shared
shm              64M  4.0K   64M   1% /dev/shm
tmpfs           3.9G     0  3.9G   0% /proc/scsi
tmpfs           3.9G     0  3.9G   0% /sys/firmware


(Jay Pfaffman) #4

I saw a similar problem yesterday. There seems to be a problem with the code that uploads the backup file. It looks like it’s not finishing and sticking all of the files together into the backup file.

We solved the problem by uploading via scp, but then something else kept the file from restoring.


#5

Seems strange, as literally have been backing up and restoring frequently over the last few days, then suddenly, new version and it stops working!

@pfaffman Not sure I have the knowledge to start performing manual file copies etc, just to get backup in and restored!

Hopefully it will be resolved soon


#7

I am also experiencing this issue.


#8

To update on this my scp of the file worked for me and restore was completed successfully.


(Alan Tan) #9

Fixed in

Thanks for reporting @thetangledweb


(Stephen Chung) #10

Same here. The only one time i tried uploading backup it didn’t show on list. And the file wasn’t there.

Ended up using scp to upload the backup file.


(Alan Tan) #11

This topic was automatically closed after 31 hours. New replies are no longer allowed.