Install only asks for smtp password


#1

I’m trying to install Discourse in a Debian server following the 30 min install guide but when I run:

./discourse-setup

I only get asked about the SMTP password and an email for Let’s Encrypt. After I type them I get an error:

Checking your domain name . . .
WARNING:: This server does not appear to be accessible at 443:443.
A connection to http://443 (port 80) also fails.

Does this look right?
Hostname      :
Email         :
SMTP address  :
SMTP port     :
SMTP username :
SMTP password : kbhgvcfxcfgvhjdi87654h3gf5d67sujwh //Some fake api
Let's Encrypt : some@email.es

And of course, they are not right, because they are blank!

Any idea what it’s happening?


(Bhanu Sharma) #2

are those values set up in containers/app.yml ?

if not,
You can either:
edit app.yml file manually and configure those values.

or
Follow that guide correctly and use the recommended os i.e. ubuntu


#3

I was expecting the initial script to create that file for me… apparently it did not.

I tried to manually change the values and run ./launcher rebuild app this return an error of Docker trying to update postgres.

After some digging I found out that the problem was that some dependencies of postgres were not installed on the system. I installed them and started the installation process again, now looks that is working.


(Bhanu Sharma) #4

That’s strange!

The ./discourse-setup script is supposed to install all the packages and their dependencies on it’s own but the word of caution is that it is known to work best with ubuntu 16.04.

I haven’t personally tried to install it on a host running on debian or any other linux distro so I’m not very sure about how it behaves across platforms.


(Jay Pfaffman) #5

Hmm. I made some changes recently. It could be that I broke something, though I believe I’ve done some installs since then.

I’ll check on this tomorrow.