Installation Issues... (First Discourse Installation Experience)


i try to install discourse for the first time on the official way with the discourse-setup script… on an Arch VPS (testing purposes with a group) - which has a fresh nginx installation - i’ve stopped an deactivated it for now… to get a working built.

The Script hangs on “Checking your domain Name…” - i’ve looked into the script and thats a call to “connect_to_port” - i guess he’s trying to connect to a 443 there… netcat is installed… if i enter for example “nc host 443” in the shell i get no output and nothing happends… i guess because the “outer” nginx is not running - so nothing is on this port… not sure what the script exactly does there.

I’d also tried to skip that test - but it seems in the end - after the build - he’s trieing something similar - that has’nt worked either. So deleted everything and started now fresh… what can i do - to get this netcat connection test running ? Maybe that solves the other problems also…

(Sorry for my horrible english… - i’m not a native speaker…)

I’ve tried it again without netcap - the build ends up with this message…

docker: Error response from daemon: driver failed programming external connectivity on endpoint app (80e0a31158301339ff7c9567079017bb795b1172ee47e1c6417c29acda3c699a): (iptables failed: iptables --wait -t nat -A DOCKER -p tcp -d 0/0 --dport 443 -j DNAT --to-destination ! -i docker0: Warning: Extension tcp revision 0 not supported, missing kernel module?
Warning: Extension DNAT revision 0 not supported, missing kernel module?
iptables: No chain/target/match by that name.

is that a docker configuration problem?

You need to remove nginx for a standard install. Discourse includes its own nginx, so you don’t need another (unless you want one for some other reason, which makes the installation more complicated).

The script attempts to connect to itself using your domain name. If the domain name points to your VM, then it should be able to contact itself via that hostname given that the DNS is correct and their is nothing else using ports 443 and 80.

If you bypass the check a bunch of times then you’ll hit limits on how many attempts you can make to get a https certificate from let’s encrypt.


Thank you.

I want a multisite Setup - so i need the reverse proxy thing… but for any more advanced guide i found here - i’ll need first a working base installation.

is there somewhere a more manual installation manual - or is it really needed to reduce the machine first totally to build later up… ?

Discourse should’nt be the only Software that will run on this machine… and i just want to have an idea how to keep it on his own layer - while accessing to it - over a public proxy layer…

Because thats a throw away machine anyway - i will try for sure… its the first time ever i have to do it for a web app - just because “to keep it easy”…

Well, you’ll setup vhost as usally in ”outer” nginx using proxy_pass http://unix:/var/discourse/shared/standalone/nginx.http.sock:; and terminating SSL there of course

Then on app.yml you have to comment out port redirections and lets encrypt and use socket instead.

Restarting nginx and rebuilding Discourse will give you an open forum :wink:

Instructions can be found here too.


That seems totally helpful to me… thank you buddy :smiling_face_with_three_hearts: i’ll work with that…