Installing Discourse on DigitalOcean - got stuck

Hi community — love Discourse. And this time around, I want to set it up myself.

I’m a complete non-programmer.

I have created a droplet in DigitalOcean. I have created an account / sub-domain in Mailgun and my credentials are ready.

However, I’m stuck here:

Access Your Cloud Server

Connect to your server via its IP address using SSH, or Putty on Windows:

ssh root@192.168.1.1
Enter the root password from the email DigitalOcean sent you when the server was set up. You will be prompted to change the root password.

I have for real never opened Terminal before today. And I don’t see a root password email. I just have the email from DigitalOcean congratulating me on my coupon and giving me set up instructions.

Question: how do I use ssh to get access to the droplet? And what kind of password am I looking for?

Thank you!

1 Like

log into your account and go do a password reset.

it will mail you one big long ass password.

then when you login its gonna tell you to change ur password

2 Likes

The last time I did this I got an email with the password, which you then have to change the first time you log in. You can also reset it via the digital ocean website.

Terminal and ssh is not so hard - google can be your friend when you are trying to figure out how to do things.

Keep us posted here on your progress! :seedling:

1 Like

Cool. By log in you mean — using Terminal / SSH or the DigitalOcean website?

1 Like

It’s working! Nearly there, I think.

1 Like

Now: 403 error.

Okay. It installed — everything seemed to work….

(And I have created an A record in Siteground, where my site is hosted / where the name servers are, to point at my IP address of my droplet.)

But now I can’t access the installation on my browser. When I go to start the log in / admin creatio stage, I arrive at:

403 - Forbidden Error
You are not allowed to access this address.
If the error persists, please contact the website webmaster.

If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

Common reasons for this error are:

Incorrect file/directory permissions: Below 644.
In order files to be read by the webserver, their permissions have to be equal or above 644. You can update file permissions with a FTP client or through cPanel’s File Manager.

Restrictive Apache directives inside .htaccess file.
There are two Apache directives which can cause this error - ‘Deny from’ and ‘Options -Indexes’.

Unless you specified a droplet with Cpanel installed, that shouldn’t be occurring and likely means DNS hasn’t propagated yet.

Try a service like this:
https://www.whatsmydns.net/

To check the status of your DNS for the A record

1 Like

Thank you. I did not specify a droplet with cpanel installed — unless I did something wrong.

It may be just a time delay. I’ll check again tomorrow.

(However, that site whatsmydns.net shows a series of green ticks when I check the DNS for the A record. So maybe it HAS propagated?)

The 1-click installer is sort-of a standard install, but it keeps you from knowing the way that you’re supposed to do stuff.

You really need to follow the Discourse official Standard Installation. I think, though, that you can ssh (or use the console) to access your server as you have done already and

cd /var/discourse
./discourse-setup

If that works, then you can say you have an “official install” and you’ll know that stuff like ./launcher rebuild app will work.

2 Likes

I’m confused by your comment – that’s what I thought I was doing. I followed those instructions.

It was a DNS issue more than a setup issue.

1 Like

Thank you for your help! Now I’m working through an email issue… Getting there.

I would add that there are real blocking points in these standard instructions for people who are not familiar with SSH / Terminal. For instance, I didn’t know that when I start typing in a password, nothing appears in the box – so something seemed to be broken. At other moments in the instructions, the text offered isn’t actually what you are supposed to type into the command line. Googling / searching the forums fixes these things eventually, but it has been a slow process and some annotation of the instructions for newbs / regular folk / non-programmers would be helpful.

Follow this guide.

1 Like

Thanks Gavin - already did! I think it’s fixed now. I had put the wrong thing in one of my email set up fields.

3 Likes