Intermittent erroneous no permission for new topic

I’m currently running 3.3.0.beta4-dev (16a8a31c52), but this is fairly intermittent so I’m not sure how long it’s been going on. I’ve seen it a handful of times earlier, but only just now got a report of someone else experiencing it.

Sometimes when opening a category, the new topic button is grayed out and it says that you don’t have permission to post a new topic, even when the person does. Refreshing the page has fixed it in every case that I’m aware of. I think I’ve seen it occur in categories where everyone has permission to post, but unfortunately I’m not sure and don’t have much information because it happens so rarely.

If there’s anything I can do to get more info next time someone experiences it, please let me know.

What plugins are you using?

Plugins are:

  • discourse/docker_manager.git
  • discourse/discourse-openid-connect.git
  • discourse/discourse-reactions.git
  • discourse/discourse-gamification.git
  • discourse/discourse-solved.git
  • discourse/discourse-staff-alias.git
  • discourse/discourse-user-notes.git
  • discourse/discourse-data-explorer.git
  • discourse/discourse-cakeday.git
  • discourse/discourse-bbcode.git
  • discourse/discourse-templates.git
  • discourse/discourse-restricted-replies.git
  • discourse/discourse-assign.git
  • discourse/discourse-docs.git
  • discourse/discourse-chat-integration.git
  • singerscreations/discourse-stopforumspam.git
  • paviliondev/discourse-custom-wizard.git
  • discourse/discourse-math.git
  • paviliondev/discourse-legal-tools.git

The enabled theme components are:

  • discourse/discourse-category-banners.git
  • discourse/DiscoTOC.git
  • discourse/Discourse-easy-footer.git
  • discourse/discourse-icon-header-links.git
  • discourse/discourse-tag-banners.git
  • discourse/discourse-versatile-banner.git