Invalid byte sequence error during install


#1

We tried to install discourse on Ubuntu 16.04 and everything went smoothly until we got this error. Anyone can figure out what is wrong and how to fix it?

Updates successful. Rebuilding in 5 seconds.Building appWARNING: We are about to start downloading the Discourse base imageThis process may take anywhere between a few minutes to an hour, depending on your network speedPlease be patientUnable to find image 'discourse/base:2.0.20180404' locally2.0.20180404: Pulling from discourse/base22dc81ace0ea: Pulling fs layer1a8b3c87dba3: Pulling fs layer91390a1c435a: Pulling fs layer07844b14977e: Pulling fs layerb78396653dae: Pulling fs layeref3e3cc07f1b: Pulling fs layer07844b14977e: Waitingb78396653dae: Waitingef3e3cc07f1b: Waiting1a8b3c87dba3: Verifying Checksum1a8b3c87dba3: Download complete91390a1c435a: Verifying Checksum91390a1c435a: Download complete07844b14977e: Verifying Checksum07844b14977e: Download completeb78396653dae: Verifying Checksumb78396653dae: Download complete22dc81ace0ea: Verifying Checksum22dc81ace0ea: Download complete22dc81ace0ea: Pull complete1a8b3c87dba3: Pull complete91390a1c435a: Pull complete07844b14977e: Pull completeb78396653dae: Pull completeef3e3cc07f1b: Verifying Checksumef3e3cc07f1b: Download completeef3e3cc07f1b: Pull completeDigest: sha256:745365df6e01943d48cbe4c59214c76ac302def2d00a07aff07d625b306bbeb7Status: Downloaded newer image for discourse/base:2.0.20180404Ensuring launcher is up to dateFetching originLauncher is up-to-datecd /pups && git pull && /pups/bin/pups --stdinAlready up-to-date.I, [2018-05-11T[15:33:59](http://llink.to/?u=https:%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DBN-aGctqafY%26t%3D56039s&e=1e2d4541eb3bcabc984c1b935e42de0b).080291 #13] INFO -- :slight_smile:
loading --stdin/pups/lib/pups/cli.rb:15:in `split': invalid byte sequence in US-ASCII (ArgumentError) from /pups/lib/pups/cli.rb:15:in `run' from /pups/bin/pups:8:in `<main>

* FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than oneroot@tamigut:/var/discourse#

(Bhanu Sharma) #2

What is your system locale set to?

Enter locale in terminal to check what the defaults are set to.


#3
Sais "LANG=C
LANGUAGE=
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

(Bhanu Sharma) #4

Run the following command:

sudo dpkg-reconfigure locales

then select and enable en_US.UTF-8 UTF-8 and default it to en_US.UTF-8 on the next page.

after that, Run ./discourse-setup once again. this should be fixed.


#5

We tried, restarted but still get this error:

[2018-05-14T13:23:48.558704 #13] INFO -- : Loading --stdin
/pups/lib/pups/cli.rb:15:in `split': invalid byte sequence in US-ASCII (ArgumentError)
from /pups/lib/pups/cli.rb:15:in `run'
from /pups/bin/pups:8:in `<main>'

** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Rafael dos Santos Silva) #6

Your app.yml has invalid data. Please fix it.


#7

What is app.yml? We used docker to download the latest release of Discouse and the server setup is totally new and fresh? We didnt do any modifications other than the local reconfig as suggested by Bhanu.


(Rafael dos Santos Silva) #8

SSH into the machine and then:

cd /var/discourse
nano containers/app.yml

That’s where all your config lives. You have a bad character there somewhere. Pasting the contents into http://www.yamllint.com may help you find it.


#9

I solved it - the installation had added an ^ to the admin email.


(Régis Hanol) #10