Invalid reference format on launcher rebuild

I am suddenly getting the following error on launcher rebuild. These are for discourse instances that have been running for years without a problem and the YAML file is untouched from the last time that rebuild worked successfully to update discourse. Any help would most sincerely be appreciated.

Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
cd /pups && git pull && /pups/bin/pups --stdin
/usr/bin/docker: invalid reference format: repository name must be lowercase.
See '/usr/bin/docker run --help'.
cat: cids/app_bootstrap.cid: No such file or directory
"docker rm" requires at least 1 argument.
See 'docker rm --help'.

Usage:  docker rm [OPTIONS] CONTAINER [CONTAINER...]

Remove one or more containers
rm: cannot remove 'cids/app_bootstrap.cid': No such file or directory
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

Also I tried to look in /pups and it indicates there is no such directory?

I am able to get the discourse instance back up and running by simply starting the container again.

Check this thread. It is fixed up. But you might have the issue described.

1 Like

Thank you!! It appears that commenting out:


fixed this issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.