Invite links to topic send user to home page, not to topic

@dan I swear I tested all this back when we implemented the latest changes, but I can reproduce this bug. It affects only invite links, not invite emails. To repro:

  1. go to a topic, select :link: share button on topic menu, and create invite to the topic. If it’s in a secure category, add a group to add the user to. (bug can be replicated in either case). Save link and copy it to clipboard.
  2. Paste link into address bar in incognito mode to accept the invitation. Fill in required fields (password not required - bug can be replicated whether or not you provide a password) and submit form.
  3. In your email, click the link to confirm your email address and log in (or to add your password, if you did not specify one).
  4. You will be taken to the home page, not to the topic you wre invited to. :sob:
  5. If you added the user to a group, you can confirm this by looking at the user’s admin page.
1 Like

It was working for me the other day? I could only get sent to the homepage under specific conditions (eg. the password side-step). I think the only step that differs in my run-through compared to yours is that I copied the activation URL from the email to paste into a separate browser.

I was using my mobile, so Android/Chrome for the admin, and Android/Firefox to accept the invite for the test user. And gmail for the email.

Right… if you invite someone by email the process works as designed. The link in the email contains all the magicks to get the appropriate person immediately onboarded wiht the known and correct email address.

The problem is if you invite someone by link, not by email, using the Save invite button and then copying the link that is shown and sharing that. If you don’t limit by email, the person you are inviting has to do the email confirmation step which leads to them not being sent to the topic when they log in for the first time.


My test was using the copy link, not restricting to email. :man_shrugging:

Oh. Sorry, you wrote…

… which I misread.

Maybe there is an admin setting that is different on our sites? Let me take another look but I got exactly the repro I describe above in my latest tests, on an invite only community. Edit: just tested again, and still get sent to the home page.


Ahh, mine is not invite-only. I must have missed this in @gassim’s set up. That may account for the difference.


Just tried it here on meta, to a topic in a secure category, and I get the same repro. Not sure what’s different about your site and the ones I am testing on.


Hi @JammyDodger,
Thanks, but the community is an open community; however, we have one category which is private and doing the same steps as @tobiaseigen with the same result.

Thanks @tobiaseigen for following up!


This is most intriguing. I’ve just updated to latest, and all my invite admin settings appear to be default, and I’ve just run the same test again and I land on the right ‘arrive at topic’ topic.

I ran it again with invite only enabled, and that also landed me on the right page.

However, skipping a password on sign-up, and then setting one through the email prompt then lands me on the homepage rather than the ‘arrive at topic’ topic.

I don’t know why mine works? Is there anything I could change to try and replicate?

@JammyDodger are you signing up as a new user? The issue happens only if you sign up as a new user; however, if you sign-in the link will work as expected.

@tobiaseigen Please let me know if you’re able to replicate @JammyDodger steps. I tried all the different ways but any new user will be sent to homepage instead of the private topic in the private category.


I’m signing up a test user for the very first time.

This is my screenshot again so you can see the welcome overlay on top of the topic the test user first landed on, and that it’s in a private category:

Mine is just a simple test site, with no alternative logins or SSO. I don’t know if that makes a difference?

1 Like

Okay thanks! You know the only difference I see between the invite links I’m creating and yours is that max uses = 1 and I didn’t try max uses = 1.

I also tried 5000 (default max) for a lot of the tests, and that worked too.

1 Like

Okay and then the final difference that I see left is the mobile!

Do you think it could work if I try mobile? I’m using Chrome on my laptop but I also tried Firefox and the same issue is persistent.

I just did another round of testing here, and I think I finally have found reproducible steps for both successfully accepting an invite and being taken to the topic as specified in the invite, and for incorrectly being sent to the homepage.

If you click the link to confirm your email in a new incognito window in chrome or safari that you hadn’t used previously to accept the invitation, you get a sequence as in the screengrab below. You click to activate your account, then to “continue”, then you land on the home page. :crying_cat_face:

If you click the link to confirm your email in the same incognito window in chrome or safari that you used to accept the invitation, you get the sequence below. You never see the screen with the second button to “continue” but are taken straight to the topic specified in the invite. :smile_cat:


The redirect URL was stored in a cookie and that can be lost if user changes browsers, uses incognito, resets cookies, etc. I added an additional step after the user activates their account to lookup the invite and redirect the user to the topic they were originally invited.


@here :point_up_2: Thank you soooo much! :heart_eyes::heart::clap:


@dan thanks for fixing this! I just did a test and it works like a charm. :magic_wand: