Invite option missing


(Michael) #1

We’re running our instance with the invite only option enabled. This used to work normally. A couple weeks ago, we noticed that we can no longer get to the invite page. Clicking Admin->Users->Send Invites (and getting to <ourUrl>/users/<username>/invited) shows the image below. We’re been experimenting with SSO, but we’ve always been able to go back to invites after testing the system.

We’re running the following plugins: discourse-hipchat-plugin, docker_manager, lazyYT, and poll. Our current login-related settings that are enabled are: invite-only, enable-local-logins, and allow-new-registrations. Everything else is disabled (although sso url and sso secret have values).

Any pointers?


#2

I encountered this same issue, happened a few weeks ago.

The only workaround I could find was the raise the ‘invite limit’ for all users. Previously it was set for 0 but admin could still send them.

Think it’s a bug?


(Michael) #3

Thanks for the pointer–our limit was set to 0. It looks like raising it solves our problem. That said, I’m not sure that this was an issue in the past. According to the logs, we had lowered the limit to 0 a couple months ago, and I’m reasonably confident we had sent invites (sent by admins) between then and now. So perhaps there was a change in admins being able to ignore the set limit?


(Jeff Atwood) #4

I do think staff should be immune to this setting @techapj can you make sure that’s the case?


(Arpit Jalan) #5

This was regressed in this commit. Fixed via:

https://github.com/discourse/discourse/pull/3528


(Jeff Atwood) #6