iOS doesn't load CSS sometimes?

Only seem to happen on iOS devices - sometimes external links open to within the same window but CSS isn’t loading. Strange and I can’t even seem to reproduce!

Looks like this:

Also found reports on other public discourse forums:

Since it was reported and fixed before I wonder if it can be related to a theme or theme component maybe? Would appreciate any help.

What errors are shown in the network logs when the CSS fails to load?

As for it theoretically being a theme/component issue, have you tried safe mode?

no simply because I saw this behaviour a few times in the last two weeks, only on my iPhone and have heard the same from users but cannot reproduce, seems random.

this looks like an old bug. I can’t reproduce anywhere at the moment and all those linked topics are at least a year old. sounds like a forum that isn’t up to date.

1 Like

Thanks, but it’s running the latest beta update :frowning:

What was fixed in that bug? I wonder if perhaps there’s a component or theme that re-generated this bug?

I’m trying to catch it again, it seems to happen occasionally - not sure how to repro. It does happen though, only in iOS afaik.

I’m using multiple iOS devices, iphone 15 pro max, ipad Air 5th gen, Macbook Air M2 and I cannot reproduce this :thinking:

What model of device and iOS version are you using?

personally iphone 12 with the latest iOS 17.4

It only happens for links outside using html a href but even then it happens occasionally only?

Would love to know what was the bug that was fixed - so perhaps I could try and trigger something to reproduce it :confused:

How do those reports relate to problems with the CSS of Discourse Forums? The first one explicitly states:

the forum is not affected by this issue

1 Like

It seems to be the same behaviour - it’s when opening an external website from within the discourse. For example, opening from

That doesn’t sound like a problem the forum is causing then, if external sites are having issues.

I thought so too, however it seems to only happen when clicking through from the forum and because I found other posts I thought maybe someone can shed a light on this - could be an iOS issue. Was easier if it was not loading CSS every time and just sometimes :sweat_smile:

1 Like

@Lilly I wonder if you could share how discourse handles href and if there’s any particular way for iOS? This seems to be a Safari related issue, but it only ever happens from within discourse going out to another domain. That other domain isn’t being loaded as if discourse is trying to locally load the html of the requested page.

We’ve already tried forcing no-cache policy and playing around with www prefix. nothing seem to work. It’s exactly the issues mentioned here:

They had the main website load from their which caused the same partial page load.

Thanks in advance!