IP Lookup not working

We’ve recently upgraded to Discourse 2.5.0.beta5.

Our moderators have let me know that IP lookup isn’t working from the admin pannel. Typically we would use this feature to gather more information about users who seem suspicious or to handle trolls.

I’ve tested it myself and I get the following:

Note: The Hostname field is filled in for some users, but not for everyone.

Steps to reproduce:

  1. Go to the profile of any user
  2. Tap on Admin in the top-right
  3. Tap on “IP Lookup” (registration or last - same result)

I’ve had a look at the console and network tabs in Chrome DevTools and I don’t see any obvious errors. Let me know if there is any more information that I can add that will help find the issue, or if perhaps I just missed something with the new update.

1 Like

You need to signup for a MaxMind free license for it to work. Details at Upgrade / Rebuilds Fail due to MaxMind DB EOL


Thank you. That solved it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.