Is this a discourse or dns issue


(Sam Behner) #1

I went through the installation on my Linux machine, I went thru the ./discourse-setup and all went well, it said it would take a few minutes for the bootstrap stuff to set up, I have my website setup to make the IP address of my VPS go to forum.origingaming.net I created that A Name around a day ago, whenever I go to my website it says:

# This site can’t be reached

**forum.origingaming.net**  is currently unreachable.

ERR_CONNECTION_FAILED

Is this due to me installing discourse wrong or is it an issue with my DNS?


#2

‘A’ record looks fine … DNS seems to have propagated … the issue is on your server I suggest.

The HTML returned is showing some basic Ember.

Are you getting any build errors?


(Sam Behner) #3

I haven’t got any errors


(Sam Behner) #4

Should I try to rerun the ./discourse-setup and see if I get any errors?


(Bhanu Sharma) #5

Looks like there is some kind of firewall blocking connections on port 80 & 443.
are you sure those ports are open? where is your forum hosted?


(Sam Behner) #6

I’m using SkySilk VPS, I’ll try to open those ports, don’t remember doing that


(Sam Behner) #7

Ok, I allowed those ports via ufw, does that take time to update?


(Bhanu Sharma) #8

You allowed for incoming right?
It should be instant.
Though it still reports connection refused to me.


(Sam Behner) #9

I did

ufw allow 84
ufw allow 443

In the terminal, is there something else I need to do?

It returned Rule Updated (v6) for both of them


(Bhanu Sharma) #10

What does it return with sudo ufw status


(Sam Behner) #11

Status: inactive

(20 chars)


(Sam Behner) #12

Should I enable it via sudo ufw enable?


(Bhanu Sharma) #13

So it’s not UFW! try contacting your customer support if they have some other network based firewall in place.
Ps: is your IP 64.190.xxx.xxx ??

Don’t complicate things by adding another variable, let it be disabled unless it is at least online.


(Sam Behner) #14

Yeah my IP starts with that, I will contact customer support now, should I ask why ufw is disabled?


(Bhanu Sharma) #15

No, You should ask them if they block public connections over port 80 & 443 with some sort of firewall, and if Yes, how to allow connections to your IP/VPS?


(Sam Behner) #16

Ok, asking right now, thanks for your help btw


(Bhanu Sharma) #17

I totally missed this, Apologies about it!

What are the outputs of:

sudo netstat -peant | grep ":80 "
sudo netstat -peant | grep ":443 "

(Sam Behner) #18

It said netstat command not found

EDIT:
Installing net-tools rn so I can do i

EDIT:
Apparently I can’t post any more messages because I’m a new member, so I’ll just edit this

When I did the netstat for “:80 “ it returned nothing, same with 443


(Jay Pfaffman) #19

If the IP works but not the domain name it’s a dns problem.


#20

Jay, not so sure … both domain and IP address are returning the same HTML for me.