Issue with UserNotificationRenderer reported in sidekiq


I’m new in this forum.
We have moved a week ago a productive phpbb forum to discourse.

I have to say, this discourse wonderfull… Everithing went well.

There is just une littel point what worries me.

Sidekiq reports…

{"type"=>"user_private_message", "user_id"=>xxxx, "notification_id"=>yyyyy, "notification_data_hash"=>{"topic_title"=>"aaaa", "original_post_id"=>zzzz, "original_post_type"=>1, "original_username"=>"uuuu", "revision_number"=>nil, "display_username"=>"uuuu"}, "notification_type"=>"private_message", "post_id"=>pppp, "current_site_id"=>"default"}
Jobs::HandledExceptionWrapper: Wrapped NoMethodError: **undefined method `with_view_paths'** for UserNotifications::UserNotificationRenderer:Class Did you mean? with_options

I didn’t find any advice about UserNotificationRenderer except

And affected file in

For me it looks like notifications or messages are not going out…
Can anybody advice how to fix this ?

For info we have v2.4.0.beta2 + 183 installed, based on docker container…

Many thanks.


Are you using any nonstandard plugins?

I don’t think so. All from discourse.
Here what we use


I was running into the same error, but was able to fix it:

  1. I upgraded Ubuntu to the latest release (still had the error).
  2. I rebuilt the app (sudo ./launcher rebuild app) which fixed things. I’m running the latest release so otherwise would have tried upgrading instead of rebuilding.

Many thanks we will try.
We run Ubuntu 18.04.
Regarding discourse what is you version now ?

Ok, after rebuild it looks ok. Many thanks for the tip.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.