Issues moving from Elastic to Mailgun


(François Douville) #1

I switched from Elastic to Mailgun, but there is something bugging with my 443 port. My site is not working and I received this message :

Check your networking configuration to see that connections to port 443 are allowed.

Where/how do I check this?


SMTP: Mailgun vs elasticemail?
(Jay Pfaffman) #2

It’s unrelated to mallgun.

My guess is that you have port 443 blocked by some Firewall.


(François Douville) #3

I don’t see port 443 when I run nestat -tulpn . I checked with DigitalOcean and Cloudflare and there is no firewalls…

This is what I see :

Checking your domain name . . .
WARNING:: This server does not appear to be accessible at forum.lepeuplier.ca:443.

A connection to port 80 succeeds, however.
This suggests that your DNS settings are correct,
but something is keeping traffic to port 443 from getting to your server.
Check your networking configuration to see that connections to port 443 are allowed.

Google: “open ports YOUR CLOUD SERVICE” for information for resolving this problem.

You should probably answer “n” at the next prompt and disable Let’s Encrypt.

This test might not work for all situations,
so if you can access Discourse at http://forum.lepeuplier.ca, you might try anyway.

Does this look right?

Hostname : forum.lepeuplier.ca
Email : francois@lepeuplier.ca
SMTP address : smtp.mailgun.org
SMTP port : 2525
SMTP username : postmaster@forum.lepeuplier.ca
SMTP password : password
Let’s Encrypt : francois@lepeuplier.ca


(Jay Pfaffman) #4

The script is trying to connect to itself with your domain name and failing.

I spent considerable time writing those words to explain the problem, if there is one. I don’t really have any better explanation.

Does your domain name resolve directly to your server?

If you are using cloud flare then in pretty sure you can’t use let’s encrypt. Like it says, you can try it if you want to.


(François Douville) #5

I don’t understand what you mean by that…

Weird because Let’s encrypt + Cloudflare was working with Elasticmail… I will give it a try with mailgun


(Jay Pfaffman) #6

Does your domain name resolve to your server or to cloud flare?

Again, this has absolutely nothing to do with mail delivery.

My guess is that the last time you ran the setup script was before you configured your domain to point to cloud flare.


(François Douville) #7

My domain name resolve (point? … sorry I’m french) to cloudflare and after to DigitalOcean

Yes you are right.

So if I am using Cloudflare, it is not necessary to use let’s encrypt to have a ssl connection?


(Jay Pfaffman) #8

(François Douville) #9

My server for my wordpress site is with Inmotion Hosting and I have a free SSL. But for my subdomain that use Discourse, I am with Digital ocean and it appears I don’t have free SSL. But before all that, this is pointing through Cloudflare and I also have a free SSL (full certificate).

It is really confusing…

Sorry I should talk through another topic, it is not related anymore to mailservice


(Christoph) #10

Yes, you do. Discourse ships with free built-in SSL support (Let’s Encrypt). If you set it up using the setup script, SSL should work out of the box. So if you are using cloudflare just for the SSL, you can just turn off cloudflare.


(François Douville) #11

Got it. I just removed Cloudflare… thanks