Just Created My First Instance But Need Help

I got the instance I created up and running a few hours ago but am having the following issues:

  • not staying logged in
  • randomly 404ing (Is it possible that my IP
  • root domain (sometimes) leads configuration wizard even though the forum is completely setup.

Also, have a couple of questions:

  • How do I make categories the homepage?
  • Hod do I properly install plugins? I’ve followed the tutorial and am still getting errors.
  • Is there a way to make make a category that redirects to an external URL?

Here’s the results from the discourse_doctor script: discourse_doctor export - Pastebin.com

Seems to be back up for now.

1 Like

Have you tried searching?

1 Like

Those are strange issues. Did you do a standard install?

Your questions should easily be solved with a search.

I’m running it with the Linode marketplace app.

I think that the connection issues were cause by DNS taking a long time to propagate or something not directly related to the install. Because it’s working great now.

Then you’ll need to get help with from the Linode folks with the following:

and probably this:

Linode’s tutorial uses the plugin installation process as explained in a post on this forum (I think by you).

The standard install is the one that’s officially supported here on Meta. There are too many variations in the one-click install style ones to be able to provide consistent support for them (and most of the people here are much more familiar with the standard one, which gives a much bigger knowledge pool to drink from :slightly_smiling_face:)

If you can, you may want to consider getting a digital ocean droplet (or similar) and following the standard install guide, instead of using the linode one.

However, you may still find useful advice and tips if you have a search. :+1:


Linode should be fine, but if you use a one-click install (including Digital Ocean’s) then you might not know how to log in to your droplet and edit your app.yml and do a rebuild. But if it’s the same as that, then you’re fine.

The errors mentioned in the first post are not ones that I’d seen before on a standard installation. Maybe you don’t have enough ram?


Is there a way to add Google Analysis to my forum?

You could search the site settings for Google. The search on the site settings is a good place to start before searching here. It searches the name of the setting, its description and its value.

I just noticed that I’d made a typo. I meant Google Analytics.

Did you search for that as I suggested and not find ga universal tracking code? In the description is “Google Universal Analytics tracking code ID, eg: UA-12345678-9; see Analytics Tools & Solutions for Your Business - Google Analytics” .

1 Like

I didn’t think of that. I’m still having issues with plugins, but at least when I attempt to install the plugin the site doesn’t end up staying down.

Wait never mind, it seems like everything got reset and all the members (-1 for some reason) were lost.

All times EST

Update: all the missing posts randomly appeared for a few seconds but disappeared again.

1m later: it just happened again.

2:10am: Is there a way I could check for updates? Maybe the version of Discoure Linode has is out of date.

2:28am: Now it’s working normally again. I think the server just needed to be restarted but still not seeing the plugins.

I ran the doctor script again, I noticed that it says that there’s an error on the line in app.yml that the docker plugin is on.

2:28am: It’s down again!!!

See here for outage tracking: Uptime Kuma

4:40pm: It was a networking issue, site is accessible again still trying to get the plugins working.


5:01pm: I think there’s a problem with the rebuild file. Whenever I run it the site seems to go down.

I think there’s a problem with the rebuild file. Whenever I run it the site seems to go down.

It sounds like you may have a typo in your app.yml. Are you making sure to follow the existing formatting when you add the plugin? Ymls are very sensitive to extra spaces, etc.

1 Like

But would that cause ports on the server to get closed? The Linode support tech I’ve been communicating with said that ports 80 and 443 got closed (and that’s what caused the site to be inaccessible).

The following is the syntax from the plugins section of the app.yml file:

# Plugins go here
## see https://meta.discourse.org/t/19157 for details
    - exec:
        cd: $home/plugins
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-follow.git
          - git clone https://github.com/discourse/discourse-bcc.git

If expected that the site week be down during the rebuild.

Are there errors when your do the rebuild?

You need to use spaces and not tabs on the lines adding plugins. I do this by copy/paste of the existing plugin and editing it.

1 Like