Latest discourse-akismet breaks Discourse stable (1.3.x)

akismet

(pjv) #1

Help; I just upgraded my forum from 1.3.4 to 1.3.5 and it seems to have killed it.

I’m using the docker install.

I tried going to /var/discourse and doing git pull and ./launcher rebuild app and it’s the same. I can see my custom header but underneath that is just white nothing.

Any suggestions on how I can get my forum back online? (I do have daily backups - though I cannot reach the backups interface).


(Régis Hanol) #4

Do you have any plugins installed? If so, try disabling them.

Do you see any JavaScript errors when loading the page?


(pjv) #5

yes:


(Régis Hanol) #6

You must have some plugins installed. I don’t see any “rewire” in the vendor file here.


(pjv) #7

I do; I have commented out and am rebuilding container now.


(pjv) #8

Seems to have been the discourse-akismet plugin. When I commented that out of app.yml and rebuilt my forum came back.

@eviltrout : I notice that you pushed a commit 6 days ago that has something to do with “rewiring” and that seems to have broken my forum.

I do want to keep akismet active though: does anyone know if there is a way to pull a specific revision of a plugin via app.yml?


(Régis Hanol) #9

Are you sure it’s akismet? It’s enabled here on meta and it works just fine.


(pjv) #10

I’m sure that when I comment out discourse-akismet and rebuild then my forum comes back.

My forum is on the stable channel (which right now means Discourse v. 1.3.5). I wonder if the HEAD version of discourse-akismet works with 1.5.x (whatever meta is running?) but not with 1.3.x.

Would be nice if there was a way to specify a particular revision of a plugin. I’m trying to find or figure out a way to do that via a github URL, but so far no luck. Maybe I’ll fork the repo, revert the last commit on my fork and use that URL instead of the official one…


(Robin Ward) #11

There is a way, I’d just like to solve the core problem and not have to resort to that. I’m going to try and reproduce with the exact set up you have later today.


(pjv) #12

FWIW, this approach worked:

I forked and just reverted the most recent commit and then used the URL for my fork in app.yml and now I am on 1.3.5 with discourse-akismet active.

@eviltrout if you could drop a note in here when the official repo again works with stable Discourse I’d be grateful so I can move back.

Thanks to @zogstrip for taking the time to shove me in the right direction to getting back online quickly.


(Robin Ward) #13

It looks like the latest commit to the tagging plugin wasn’t backwards compatible. I’ve reverted it and now if you install the latest version of tagging your site should work.


(Jeff Atwood) #14