./launcher rebuild app error './launcher: No such file or directory'


(Obiwankenoobi) #1

Hey guys. So I started with Discourse a couple of days ago and today I tried to install some plugin but couldn’t make it work. I followed this tutorial and when I get to the final stage and should have to rebuild the app I got the error ./launcher: No such file or directory notice that my /discourse is not in /var but in /Github dir so I don’t know if it’s matter. This is my first Ruby program I working on and having a rough time. Hope you could help me! Thank you!


(Andrew Schleifer) #2

Yes, it matters. Replace the cd /var/discourse with the actual location of your files.


(Obiwankenoobi) #3

Yes this is actually what I did. Instead of cd /var/discourse I did cd /Github/discourse because my files are there. And this is the error I get when trying to rebuild the app from this dir.


(Jeremy M (Jerdog)) #4

what files are in that directory? And did you do a Discourse install via Docker? If so, then do you have a /Github/docker folder (judging by your aforementioned structure)?


(Obiwankenoobi) #5

files in this dir :
Brewfile discourse.sublime-project
CONTRIBUTING.md docs
COPYRIGHT.txt images
Gemfile jsapp
Gemfile.lock lib
LICENSE.txt log
Procfile package.json
README.md packaging
Rakefile plugins
Vagrantfile public
adminjs script
app spec
bin test
config tmp
config.ru vendor
d yarn.lock

and no I installed via Vagrant using this tutorial. My discourse app is still on localhost.


(Jeremy M (Jerdog)) #6

So I am not familiar with using Vagrant, but you wouldn’t use ./launcher to reload as that’s a Docker command - which is why it’s not in the directory.


(Andrew Schleifer) #7

Then the plugin tutorial is completely wrong for your environment – that’s for “standard” installs. In a development install you should run git clone in the plugins folder.


(Obiwankenoobi) #8

Thank you!

cd /Github/discourse/plugins
git clone 

Worked! (: sorry if it was dumb question I am really new to this.