Like button does not work on archived topics

The title explaisn its self. When I lcikc the like button I get the animation but nothing else.
Video:


I dont see anything in /logs relating to this, but here’s a console error.

If you try in safe mode does liking posts work?

1 Like

I dont see the like button at all.
image

Can you reproduce this on meta? What plugins do you have in place? Are you on latest?

I am on the latest build, and here’s a list of my plugins:

I dont know what it is about that post in specific. I can like most any other posts, but that one just wont let me, so I cant do it on meta withotu knowing what causes it.

Maybe you liked and unliked it in the past? so it is an “old” post and you are no longer allowed to change your mind?

Maybe a side effect of the post revision issues?

1 Like

The post was pretty new when I had made the video because I tried to like it. I hadn’t unliked it, and the unlike timer on ym site is 48 hours.

Can you try reproducing with a shadow account? Maybe this is something about moderator posts?

Turning this into a mod post… (this now has staff color, can you like it)

As I see in the video, you archived the topic, I think that’s what caused it.

1 Like

Oh … yeah … archived topics have this surprising bug… for sure.

2 Likes

Yeah moved this back to bug.

#pr-welcome for adding a popup (when you try to like)

This topic is archived and can no longer be liked

1 Like

I would, I just need to read up on some ruby. How can I create pop ups?

We have some internal class for it, recommend you look at another pop up warning in the UI (like out of likes), this would all be done in JS actually.

1 Like

I know JS, will have a look and update you guys latertonight. Thanks :+1:

I just tested it on my test site. When I archive the topic the like button still appear and clicking that the warn modal shows. If I reload the page the like button disappear.

1 Like

Weird, how do I have it after refreshing multiple times?

did you try as admin? standard user? maybe something about the type of account. I remember seeing this on another topic on our internal instance.

Also … not first post?

2 Likes

The previous was admin account and now I tried with a tl3 non-staff account.
Edit: I checked with all account type and it seems to the modal works for me.

Turns out this is an issue with the reactions plugin, which is still na official plugin. I will open a PR to it later.

2 Likes

I will also change the text in core discourse, as the text doesn’t really mean anythign atm

1 Like