Mail doesnt work after installation

so, i have succeded in installing Discourse, on a VPS-server on Hostinger, but the mail doesnt work after installation, and the hostinger support seems to be clueless, they only said i try different ports etc i have done 4 reinstallaions now with different ports,(587, 465, 25) but still i dont work. i dont really know what is the issue. My data is (picture),…if there could be anything wrong with these data perhaps? :frowning:

Would be greatful for any help

Well, there’s Troubleshooting email on a new Discourse install.

It’s not clear what “doesn’t work” means. Did you get any error when sending? Did your check spam folder?

Hi, no by doesnt work, i mean it will not send any mail, (at all) when i try to register, with the first step in the installation process… (yes i have also checked my spam-folder) i just wont recive any mail. discourse wont send any mail… so im wondering if there could be anything with the data (picture) or anything else? i am pretty clueless myself:S

Did you do the things in the link in the first line of my message?

Yes, i have read that file before and followed all instructions, still the mail issue remain. when i run the ./discourse-doctor -command i get the result (see pic)

you are not able to connect to that port.

You can try `telnet PORTNUMBER’ with various ports until you find one that will connect. It’s a problem with outgoing traffic being blocked on your VM and/or being blocked by the SMTP server.

Thanks, i tried that and found port 465 working. so, i reinstalled after changing the file to port 465, but again, the issue remained. Mail doesnt work, still (no mail was sent to my mailbox) :frowning: so, perhaps is something with the data in the first post? or…idk

My discourse installation is on a VPS with ubuntu, and my

email is hosted in a shared plan.

I rain the “./discourse-doctor” command again with result (no mail sent) see pic…

well today i reset/restarted the smtp service at my provider (hostinger) and that seemd to do the trick. (according to the diagnostics tool atleast, see pic), but then when i started the installation/registration, again, no mail was sent, (now to Gmail)… why could this be? :confused: (btw i have checked the spam-folders/Junk mail, but i didnt recieve any mail after registration/installation


The message was delivered to your mail server. If you didn’t get it and it’s not in your spam folder then your mail server silently threw it away. A common reason is that you have it configured for some domain other than that of your forum. You can look at the logs on your mail server or seek help from someone who can.

1 Like