Mailing list mode - broken experience in transition from 1.5->1.6


(Jed Christiansen) #1

Relevant topic - Mailing list mode keeps reverting to daily updates

I help run a Discourse forum where we had actively encouraged users to check the box saying “Send me an email for every post” - aka, set mailing_list_mode = True.

With the new mailing list mode, those users all have mailing_list_mode = True, but apparently by default have mailing_list_mode_frequency = 0. As a result, they’re no longer getting the individual emails per post that they expected.

Two issues -

1 - users that previously had mailing_list_mode = True should automatically be opted-in and have the mailing_list_mode_frequency set to the relevant value. (Right?)

2 - what’s the right way to make that change at scale for our users?

cc/ @ryanwanger


Mailing List Mode - Not sending to more than just a couple of users
"Daily updates" option for mailing list mode
(Jeff Atwood) #2

Hmm we should handle this better @erlend_sh @zogstrip


(Tobias Eigen) #3

I experienced this as well, though in the end only a handful of people had mailing list mode turned on at all and were affected. I was able to write to them directly to sort it out. So it was a fairly easy transition once the settings bug was fixed. Unfortunately one of those people was my CEO who was not especially happy about it.

To find out who had mailing list mode turned on and the frequency, I used this data explorer query and then exported to csv.

SELECT user_id,mailing_list_mode,mailing_list_mode_frequency from user_options


(Ryan Wanger) #4

Just to clarify, would just setting mailing_list_mode_frequency = 1 for all the people who had mailing_list_mode set to true be the correct fix?


(Tobias Eigen) #5

Yes - I think it’s fair to assume that is correct. When I look at the data explorer results and compare against the user preferences, it matches up.


(James Kiesel) #7

I’ve put in a PR to set the frequency default correctly for folks who haven’t upgraded yet:


(Sam Saffron) #8

Hmm this only fixes brand new account going forward, there is the huge problem of “history” which is now wrong :frowning:

To get out of this pickle we are going to have to add a once off migration that sets everything 1 on that table, which means we break any people that changed stuff. @neil released a new image yesterday so, ouch.


(Sam Saffron) #10

This is fixed per:

Sorry but this is the best we can do.

  • The new default for “mailing list mode frequency” is daily, site admins can change.

  • The “mailing list” warning screen is gone cause it no longer makes sense

  • After running the migration all old accounts that had mailing list enabled will be switched to the “every email” frequency, to match old behavior.


(Felix Freiberger) #11

Should this fix also go into the beta branch? I’m holding off from upgrading right now because of this issue.


(Sam Saffron) #12

maybe, @neil can you perhaps do another bump early in your morning with today’s fixes?


(Neil Lalonde) #13

Version has been bumped!


(Sam Saffron) #14

This topic was automatically closed after 24 hours. New replies are no longer allowed.