Material Design theme icons are missing


(Merlls Rizzini) #1

Just rebuild my forum and some icons are missing, including Material Designs icons from another theme. Anyone has a idea for what happened?


(Merlls Rizzini) #2

I had this plugin installed, and removed it.


#3

I’ll update it asap, I checked this weekend, didn’t seem to have an issue, the fontawesome update must have come since then


(Merlls Rizzini) #4

Oh god, thank you. I was thinking it was something wrong I made.


(Merlls Rizzini) #5

@Steven I removed your plugin, but some icons are missing on my theme. Do you know what I can do to bring them back?


#6

You should have a new option in the admin panel : svg_icon_subset

Add the name of the icons you have to fix, and I think it might fix your other issue

I didn’t have time to test this at the moment tho


#7

I fixed my plugin, thanks for reporting the issue


(Merlls Rizzini) #8

It didn’t worked for me :frowning_face:


#9

You use a imported full theme ?

It might be best to wait for an upgrade. If it’s a heavily customized theme, it might need some other tweaks on the html


(Merlls Rizzini) #10

Yes, it is. This one, and I believe that this one won’t be upgraded. I worked and paid to fix a lot of issues, now this happens… I feel so unlucky


(Merlls Rizzini) #11

It was probably cause by this on last Discourse updated.

package.json Upgrade to FontAwesome 5 (take two) (#6673) 2 days ago
yarn.lock Upgrade to FontAwesome 5 (take two) (#6673) 2 days ago

(Stephen) #12

This isn’t really a bug, it’s just a consequence of Discourse being upgraded and the impact on third party code.

Your experience is precisely why anyone who is serious about hosting a community should have some form of test or integration environment. You need somewhere to test upgrades before they hit your public site to know whether it’s safe to upgrade. It’s still very early days for the FA5 upgrade, some of what you’ve seen may be fixed elsewhere if you give the developers time.


(Merlls Rizzini) #13

Thank you for your advice. :slight_smile:


(Jeff Atwood) #14

Yes, we should be able to give advice and assist, the priority at the moment is rolling it out as an official release and testing it against all our hosted customers. We’ll definitely share all that info as we get it.


(Joe) #16

@Merlls_Rizzini

I tried to reproduce this issue but I could not.

I used the Formatting toolbar plugin and the Daemonite Material Theme and here’s what I see:

Make sure that:

  1. Your Discourse install is on the latest
  2. You have the latest version of the the plugin
  3. The theme is updated.

If the issue still persists, it would be a lot easier if you can share a link to your site so that we can check and see what’s wrong.


(Merlls Rizzini) #17

@Steven already fixed this on editor.

I was talking about how the last Discourse upgrade with FontAwesome 5 overridde Daemonite icon’s.

After last upgrade:
48



(Joe) #18

No problem, I’m closing this topic since the issue in the OP is resolved. The issue in your post above is separate and you can follow-up with the maintainers of the theme here:


(Joe) #19